Blender > ffmpeg trouble on Gentoo Linux.[SOLVED]

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Post Reply
Ric95
Posts: 0
Joined: Thu Jan 01, 1970 1:00 am

Blender > ffmpeg trouble on Gentoo Linux.[SOLVED]

Post by Ric95 »

Whenever I try to render an animation in any ffmpeg format, Blender crashes.
Compiled on Gentoo, cflags = -o2 -march=native (I'm using amd64)
USE="ffmpeg nls openal openexr openmp player png" emerge blender-2.48

It compiled fine.

When I try an ffmpeg animation:
Starting ouput to /tmp/0001_0007.d d(ffmpeg)...
Using type=1, codec=2, audio_codec=86016,
video_bitrate=6000, audio_bitrate=128,
gop_size=15, multiplex=0, autosplit=0
render width=720, render height=576
[dvd @ 0*14c29eo]Aspect ratio mismatch between encoder and muxer layer
Output #0, dvd, to '/tmp/0001_0007.dvd':
Stream #0.0: Video: mpeg2video, yuv420p, 720*576 [PAR 1:1 DAR 5:4], q=2-31, 6000 kb/s, 90k tbn, 25 tbc
Writing frame 1, render width=720, render height=576
[mpeg2video @ 0x14c3a10]rc buffer underflow
Video Frame PTS: 0
Floating point exception

The first frame renders, then both blender and the render window close. The avi file is created, but is empty.
What am I doing wrong?
Last edited by Ric95 on Sun Sep 20, 2009 2:25 am, edited 1 time in total.

Ric95
Posts: 0
Joined: Thu Jan 01, 1970 1:00 am

Post by Ric95 »

The newer gcc compiler has the option to auto-detect the cpu options, so I used the cflag ' -march=native'. But I needed to use the correct cflag ' -march=k8'. ( k8 for amd64 family of cpus)
Its worth knowing that 'test.blend' rendered 3 seconds faster with the k8 flag than it did with the 'native' flag. I think its safe to say that GCCs 'native' function isn't mature yet.

Post Reply