Page 1 of 2

Error when building in 64-bit..

Posted: Mon Jan 25, 2010 9:01 pm
by JSvard
Ok, I'm new at this, at least - I've never built blender before, and just followed the guide for 64-bit windows here:
http://wiki.blender.org/index.php/Dev:D ... .5/Windows

I get this error on two computers - what am I missing?

scons: *** Visual Studio version 9.0Exp does not support archite
File "C:\BlenderSVN\blender\SConstruct", line 128, in <module>

Posted: Tue Jan 26, 2010 12:10 am
by stiv
Having the actual error message is useful. From the beginning of the first one, it looks like your compiler does not support 64 bit.

Posted: Tue Jan 26, 2010 1:47 pm
by JSvard
stiv wrote:Having the actual error message is useful. From the beginning of the first one, it looks like your compiler does not support 64 bit.
Thanks.
Any suggestions to how to solve the problem since I use the recommended MS VC++ Express 2008? I am starting the 64-bit command prompt with x64 as "option".

Posted: Tue Jan 26, 2010 8:31 pm
by stiv
Summary: you need a compiler that supports building 64 bit applications.

Permit me to read from the link you so helpfully provided:

Download and install the following applications and libraries:
1. Visual Studio 2008 or the free VC++ Express 2008. VC++ Express can't build 64-bit though!

The underlined part seems relevant to your problem.

Posted: Tue Jan 26, 2010 8:51 pm
by JSvard
stiv wrote:Summary: you need a compiler that supports building 64 bit applications.

Permit me to read from the link you so helpfully provided:

Download and install the following applications and libraries:
1. Visual Studio 2008 or the free VC++ Express 2008. VC++ Express can't build 64-bit though!

The underlined part seems relevant to your problem.
This was news to me and I didn't see it or it was edited in a few days ago. (Last edit is late today) Thanks for pointing that out for me!

.

Posted: Wed Jan 27, 2010 3:49 am
by stiv
This was news to me and I didn't see it or it was edited in a few days ago.
Heh. According to the revision history, it was, indeed.

Posted: Sun Jan 31, 2010 5:25 am
by pep
Hope this is the right thread :roll:

I am trying to build blender 2.5 with gcc 4.4-4.2-x86_64 on linux Suse 11.2 with Intel Core i7 CPU 920 @ 2.67GHz and 6 gb memory.

All i get is

/home/pep/blender-svn/blender/intern/elbeem/intern/solver_main.cpp: In member function ‘void LbmFsgrSolver::mainLoop(int)’:
/home/pep/blender-svn/blender/intern/elbeem/intern/solver_main.cpp:1707: internal compiler error: Segmentation fault

Seems that this is a old problem in Blender, not gcc, but i couldn't find any clue to go on.

This is my first attempt to build Blender, so maybe i'm doing silly things easy to spot...
thanks for your help

Posted: Sun Jan 31, 2010 12:47 pm
by stiv
internal compiler error: Segmentation fault
I would try a different version of gcc.

Posted: Sun Jan 31, 2010 3:35 pm
by pep
Thanks stiv, i did it.
It took a little because a lot of dependencies where broken, but finally i installed gcc 4.4-5.1-x86_64 from openSuse:Factory and it worked.

Compilation before the change stopped at 15% with the segmentation fault error and now goes on until 51% with a different error:

Python.h: No such file or directory

i'll try to hunt the solution for myself but any help is welcome

Posted: Sun Jan 31, 2010 3:53 pm
by stiv
Python.h: No such file or directory
General rules for compiling:

- No such file error means you either did not install the necessary headers or your include paths are not set correctly

- undefined reference error means you did not install a library or your link paths are not set correctly

- on linux, packages come in two parts: the libraries and the header files. for any package foo, there is a foo and foo-dev (or foo-devel). To run an application you just need foo. To compile an application, you need both.

Posted: Sun Jan 31, 2010 3:54 pm
by pep
Found it.
seems that 2.5 compiles with python 3 and OpenSuse calls it python3 so i had to install python3-devel
and now i get up to 83%...

still hunting
:)

Posted: Sun Jan 31, 2010 4:11 pm
by pep
General rules for compiling:

- No such file error means you either did not install the necessary headers or your include paths are not set correctly
Actually at 83% i get

COLLADAFWRoot.h: No such file or directory

now the problem is that i have no idea of where to find Collada libraries, or how to set the include path or how to switch off Collada support...

...did i mention that i am a totally naive wannabe programmer?

Posted: Mon Feb 01, 2010 12:39 am
by kidb
pep wrote: COLLADAFWRoot.h: No such file or directory
http://wiki.blender.org/index.php/User: ... ada_Branch

or set BF_COLLADA=False in your user-config.py

Posted: Mon Feb 01, 2010 3:20 am
by pep
kidb wrote: COLLADAFWRoot.h: No such file or directory

http://wiki.blender.org/index.php/User: ... ada_Branch

or set BF_COLLADA=False in your user-config.py
thanks kidb, i looked at the link but it was really too much for me (maybe after a compiled Blender without Collada...)

I went for the second option but couldn't find user-config.py, so i looked in blender-svn/blender/CMakeLists.txt and found a place where it was possible to mark Collada off (naive programming :roll: ) and now it compiles up to 100% but then stops with
copying a subset of the systems python...
cp: cannot stat `/usr/lib/python3.1': No such file or directory
make[2]: *** [bin/blender] Error 1
actually python 3.1 is in /usr/lib64/python3.1

and i'm stuck again : how can i change the string?
thanks for your help

Posted: Mon Feb 01, 2010 5:32 pm
by stiv
but couldn't find user-config.py,
Read doc/blender-scons.txt in the source tree.

You need to create user-config.py. The easiest way is to copy your platform specific config file up one directory. Make your changes to the new user-config.py.

It is a common mistake to run back and forth between the various build systems without taking the time see how to set them up for your configuration.