Compiling Blender 2.56 on CentOS 64bit

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Post Reply
ragtag
Posts: 0
Joined: Fri Jan 21, 2011 3:24 pm

Compiling Blender 2.56 on CentOS 64bit

Post by ragtag »

I'm new here, so hi all.

I'm trying to get Blender 2.56 to run on CentOS 5.3 x86_64. When I try to run the latest pre-compiled version it complains with the following error:

Code: Select all

./blender: /lib64/libc.so.6: version `GLIBC_2.6' not found (required by ./blender)
./blender: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by ./blender)
This, of course, makes perfect sense as CentOS 5 runs glbic 2.5. Since I don't really want to mess with upgrading glibc, which would likely break the whole OS installation, is it possible to compile Blender 2.56 against glibc 2.5?

I already have a custom compiled Python 2.5.4 installed, so that's shouldn't be a problem.

Cheers,

Ragnar

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv »

I already have a custom compiled Python 2.5.4 installed, so that's shouldn't be a problem.
Having it installed is not a problem, but Blender 2.5x uses Python 3.

Older versions of Blender were compiled against older glibc versions. Give it a try and let us know!

ragtag
Posts: 0
Joined: Fri Jan 21, 2011 3:24 pm

Post by ragtag »

I've got 2.49 running just fine on CentOS, I was just hoping there was a way to get the latest and greatest version running too. I have it on Ubuntu, and the improvements done look great.

Didn't notice that it was using Python 3, but then I'm guessing it comes with it's own version. My Ubuntu 10.04 install comes with Python 2.6.5, but in the script console in Blender 2.56, it shows 3.1.1.

Were older versions of 2.5x compiled against older glibc, or just 2.4x versions?

ldo
Posts: 0
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Post by ldo »

You shouldn’t be doing this kind of thing on CentOS.

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv »

Were older versions of 2.5x compiled against older glibc, or just 2.4x versions?
Most likely, 2.5x has been compiled against newer glibcs simply because they are the currently available versions. I cannot think of a specific reason why glibc 2.5 would not work. If you can build all the dependencies, compiling blender should not be a problem.

Try it and find out!

RipSting
Posts: 5
Joined: Wed Nov 27, 2002 1:58 am
Location: Oregon, USA
Contact:

Post by RipSting »

Was any progress made on this? We have a server cluster running CentOS 5. It's critical getting Blender 2.5.7 up and running on it with support for network rendering. Would it be a waste of time trying to compile Blender 2.5.7 with GLIBC 2.5? This is urgent...

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv »

This is urgent...
No reason I can think of off-hand why it will not work. But better get compiling! Running ldd says my blender is linked against 50 some libs and they all need to be compiled with the same libc.

RipSting
Posts: 5
Joined: Wed Nov 27, 2002 1:58 am
Location: Oregon, USA
Contact:

Post by RipSting »

stiv wrote: Running ldd says my blender is linked against 50 some libs and they all need to be compiled with the same libc.
Ouch. I've only successfully built Blender on Windows, and that was over a year ago. This is certainly above my level of comfort. I'm going to push to have the OS changed to Ubuntu LTS or another modern OS with Glibc 2.7+.

Nico_GA
Posts: 0
Joined: Tue Apr 19, 2011 4:16 am

Post by Nico_GA »

RipSting wrote:
stiv wrote: Running ldd says my blender is linked against 50 some libs and they all need to be compiled with the same libc.
Ouch. I've only successfully built Blender on Windows, and that was over a year ago. This is certainly above my level of comfort. I'm going to push to have the OS changed to Ubuntu LTS or another modern OS with Glibc 2.7+.
i built it a couple of times, but you need to compile other libs that are not provided as well. main point is still: it works :)

Post Reply