Page 1 of 1

Latest Tuhopuu Build

Posted: Wed Aug 13, 2003 1:38 pm
by leinad13
Has anyone got a recent build of tuhopuu or tuhopuu2 for windows, i used to be able to compile with cygwin and GCC but now this damn DNA.c error messes it all up. I want a recent version because i hear it has some kind of Yafray integration, which i would like to test.

Re: Latest Tuhopuu Build

Posted: Wed Aug 13, 2003 3:42 pm
by _florian_
What's the errormessage?

Try to delete the files in /obj/windows/blender/makesdna/
Then make again.

Florian

Posted: Wed Aug 13, 2003 3:51 pm
by theeth
no problem compiling here using MSVC.

Martin

Posted: Wed Aug 13, 2003 8:09 pm
by leinad13
All i get is an error saying that it is not a valid developer studio project file, do you want to continue, i say yes and then try a build and i get this

Code: Select all

NMAKE : fatal error U1052: file 'blender.mak' not found
Stop.
Error executing NMAKE.

blender1.exe - 1 error(s), 0 warning(s)
Please can someone fix the DNA.c error, i have nothing in obj directory and it will still not compile. I always use make clean as well while using Cygwin.

Posted: Wed Aug 13, 2003 8:17 pm
by theeth
did you build the internal library?

Martin

Posted: Wed Aug 13, 2003 8:24 pm
by leinad13
I'm using Cygwin and Hos' 'free_windows-env.sh' script to compile. Everything was dandy untill a couple of weeks ago where i got an error saying sumthing about DNA.c not being able to read or sumthing. Heres the exact error which even tho i deleted the stuff in obj i still get.

Code: Select all

gcc -mwindows -mno-cygwin -o /tuhopuu/blender/obj//windows/blender/makesdna/make
sdna /tuhopuu/blender/obj//windows/blender/makesdna/makesdna.o   \
/tuhopuu/blender/lib//windows/guardedalloc/lib/libguardedalloc.a
/tuhopuu/blender/obj//windows/blender/makesdna/makesdna /tuhopuu/blender/obj//wi
ndows/blender/makesdna/DNA.c
make[4]: *** [/tuhopuu/blender/obj//windows/blender/makesdna/DNA.c] Error 1
make[4]: Leaving directory `/tuhopuu/blender/source/blender/makesdna/intern'
make[3]: *** [all] Error 1
make[3]: Leaving directory `/tuhopuu/blender/source/blender/makesdna'
make[2]: *** [all] Error 1
make[2]: Leaving directory `/tuhopuu/blender/source/blender'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/tuhopuu/blender/source'
make: *** [app] Error 2
make: Leaving directory `/tuhopuu/blender'
Its really starting to annoy me. I dont do anything with libraries specifically, i just 'source free_windows-env.sh' then 'make'. Thats all.

Posted: Fri Aug 22, 2003 5:54 am
by ascotan
All i can tell you is that i used to get the dna.c error too. Dna.c is a source file created by the makesdna module. Once the module compiles correctly dna.c is written to your drive - then you'll be able to continue. You have to compile the makesdna module first. The dna.c file is just a long string of bytes representing all the serializable classes in blender. (i think)