Page 1 of 1

audspace errors compiling scons-on-ubuntu build path

Posted: Fri Oct 14, 2011 12:26 am
by kestion
I'm trying to build blender using scons on ubuntu 11.04 using an svn fetch from Oct 08, 2011.

I've disabled FFMPEG, JACK and OPENCOLLADA in user-config.py as discussed in the windows-scons build path tutorial. They give errors.

I now get the following from python2.7 scons/scons.py

intern/audaspace/intern/AUD_FileWriter.cpp: In static member function ‘static void AUD_FileWriter::writeReader(AUD_Reference<AUD_IReader>, AUD_Reference<AUD_IWriter>, unsigned int, unsigned int)’:
intern/audaspace/intern/AUD_FileWriter.cpp:82:22: warning: comparison between signed and unsigned integer expressions
Compiling ==> 'AUD_NULLDevice.cpp'
Compiling ==> 'AUD_FileFactory.cpp'
Compiling ==> 'AUD_ResampleReader.cpp'
...
Compiling ==> 'AUD_C-API.cpp'
In file included from intern/audaspace/intern/AUD_C-API.cpp:74:0:
intern/audaspace/SDL/AUD_SDLDevice.h:37:17: fatal error: SDL.h: No such file or directory compilation terminated.


It seems that either the trunk svn was incomplete, or turning off modules causes problems with dependencies (includes).

Any help on getting around this?

kestion

ps. It would be nice if there were a reasonably recent and stable release of blender that newbie developers could compile for the first time so we don't have a crossing-the-beams of trunk problems and user's system problems.

I spent 5 days getting blender to run under windows and now 3 days (so far) getting it going under ubuntu.

"Whatever you do...never, ever cross the beams."
- Ghostbusters

Posted: Fri Oct 14, 2011 4:44 am
by stiv
fatal error: SDL.h: No such file or directory
General rule of thumb:

No such file means you did not install the header files for some package (on Linux, you need to -dev or -devel packages). Or the include paths are bad in your configuration.

Unresolved symbols mean you did not install the necessary libraries. Or the library paths are bad in your config.

For a given package 'foo', you need 'foo' for the libraries and 'foo-dev' or 'foo-devel' for the header files.

Likely, the problem here is you need to install the sdl-dev or sdl-devel package for your distribution.

Posted: Fri Oct 14, 2011 4:53 am
by Tehrasha
Google ubuntu and SDL.h and you should be able to locate what package you need to install.

Posted: Fri Oct 14, 2011 5:45 am
by kestion
Tehrasha wrote:Google ubuntu and SDL.h and you should be able to locate what package you need to install.
Thanks, i'm on it. But why wouldn't SDL.h be bundled with the dependency libraries i downloaeded. Is the tutorial out of date and missing added libs?

I'm following:
http://wiki.blender.org/index.php/Dev:2 ... untu/Scons

ps. Where should i put the library and SDL.h?

Posted: Fri Oct 14, 2011 6:30 am
by kestion
ps. Where should i put the library and SDL.h?
OK. I was able to fix my ubuntu software center. I had configured default python to be python3.2 . The "install" button no longer worked. I pointed back to python2.7 and everything's fine. Software Center decides where to put libraries.

from the terminal:
sudo apt-get install libsdl1.2-dev

Posted: Fri Oct 14, 2011 6:31 am
by Tehrasha

Code: Select all

sudo apt-get install libsdl1.2-dev
According to Ubuntu's package search engine, it should be in that package.
And it will put it in the proper place when in installs.

Posted: Sat Oct 15, 2011 7:08 am
by kestion
some tips on searching for libraries

I used the ubuntu software center first which worked half the time.
if that failed i search using the ubuntu package search http://packages.ubuntu.com/ and then did a
sudo apt-get install library

Both these programs automatically select where to install the files and keep track of versions and dependencies.

some missing libraries are found easily.
others you need to drop the l, for example the package search could not
find ltk8.5, but it did find tk8.5.
a few older libraries may be bundled into new ones that have completely different names. libiconv was the hardest to find since there were so many choices. I eventually found http://www.gnu.org/s/libiconv/#TOCdownloading
and was able to nearly get it to work following the instructions.
(also needed to run $ldconfig after the config, make, install)

another very helpful troubleshooting suggestion from IRC #ubuntu was
blender-svn/build/linux/bin$ ldd ./blender
ldd is run from the directory where the blender.exe is found and gives info on all the library dependencies and locations, in case you are able to compile but blender won't link when you try to execute it.

hope that helps someone
kesten

Posted: Sat Oct 15, 2011 7:18 am
by Tehrasha
Also try http://pkgs.org/ where you can search for a specific missing file, and it will tell you what package it can be found in for multiple flavors or linux.