Compiling on Mac 10.3 Panther Tutorial

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Post Reply
Posts: 13
Joined: Wed Oct 16, 2002 4:37 pm
Location: Lehigh Valley, PA USA

Compiling on Mac 10.3 Panther Tutorial

Post by jsplifer »

Compiling on Mac 10.3 Panther Tutorial
By: jsplifer

Hello fellow Blender users. Compiling Blender on the Macintosh couldn't be easier. Here is my solution to getting the Blender3D application running on Mac OS 10.3 Panther.

Step #1 Dependencies

The first step, is to make sure you have the necessary dependencies needed for compiling Blender. I found the easiest way to do this is through the use of Fink. This is a package manager that will retrieve and install many open source projects. I highly recommend this application, please get it from here in the downloads section:

Once the disk image has downloaded and mounted, you will see the package Installer, and a folder named FinkCommander. Double click the FinkCommander folder to expose the FinkCommander application, drag this to your "/Applications" folder. Go back up a level and install the Fink 0.6.2 Installer.pkg by double clicking it.

After the installation is complete you will want to execute FinkCommander now hopefully located in your "/Applications" folder. Upon opening it is recommended that you update the installation and list of programs. Do this by clicking "Source" in the toolbar and selecting "Selfupdate-rsync". Fink will retrieve the latest version info. To view the full list of applications goto FinkCommander's "Preferences..." window and choose "Fink" from the tabs. Select "Use unstable packages" and "Use unstable cryptography packages". You may need to "Selfupdate-cvs" again to make this setting stick. You should see about 2,500 packages. Note, you will need admin permissions to use this application, you will also need Apple's X11, BSD subsystem and Developer tools installed, all included in your Panther 10.3 disks. Talk to you system administrator if you need help.

In the upper right hand corner of FinkCommander is a search box, use it to quickly locate the following package:


You may also choose to download other packages used by Blender via the FinkCommander. The following are available either on your system now or are located in the Blender CVS repository so they are not a necessary download for compiling, however they will be the most recent for development purposes:


These are installed by highlighting their name in the list and then accessing "Source" in the toolbar and choosing "Install". You should see Fink fetching the source code and then compiling the source into an executable. Onto Step #2 :)

Step #2 CVS Checkout

Much the same way Fink goes about fetching source code and compiling it, we will do the same, but manually. One of us Mac people should really decide to maintain a Blender package available through Fink. Hint Hint.

I will now have you install a graphical user interface for CVS, it is what FinkCommander is to Fink. You can get it here:

Once the compressed package has downloaded, double click it and install the application into your "/Applications" folder. Once installed run the application and enter the program's "Preferences..." In the "Login Profiles" tab enter a descriptive name for this profile. I have used "BF-Blender" as my profile name. The remainder of the settings:

Repository access method: Pserver
Port: Default 2401
Root: /cvsroot/bf-blender
User: anonymous
Password: No Password

You can hit "Test" and see if the client connects. Push "OK". From "Repository" in the menu bar, choose "Check Out..." and enter the following:

Login: BF-Blender
Module: blender
Folder: Here you must choose a spot for this stuff.

After downloading is complete get the extra stuff. Most of these extra libraries are available through Fink or accessible through your newly installed cvs client. Some editing of files will be necessary if you choose this route however you can be assured of having the most current version, which can be good for development purposes. But again, the Blender devels are kind enough to supply them all in one download, so continue to download from cvs by choosing "Repository", "Check Out..." with these settings:

Login: BF-Blender
Module: lib/darwin-6.1-powerpc
Folder: Here choose the same folder where you put the blender module

Ok, a few edits and we can sit back and let the cpu do the rest, lets go...

Step #3 Edit

If you are using OSX Panther you have long surpassed the Darwin version of 6.1. If you keep your OS current by using the Software Update feature than you will most likely be at version 7.5.0 at the time of this writing.

It seems Blender is looking for things in the folder named "/darwin-6.1-powerpc" but at the same time it's needing a folder for the current version "/darwin-7.5.0-powerpc". The solution is a symbolic link. Using the Terminal application, located in"/Applications/Utilities/Terminal", goto the folder containing "/darwin-6.1-powerpc". In my installation, I typed:

Code: Select all

jaspermine$ cd /Volumes/MacFilez/Development/Blender/lib/
To view what's in here type the following:

Code: Select all

jaspermine$ ls
And to add the symbolic link which is basically an alias:

Code: Select all

jaspermine$ ln -s darwin-6.1-powerpc darwin-7.5.0-powerpc
One more thing to do before you type the magical phrase. You must add some of the things located in "lib/darwin-6.1-powerpc" to the systems table-of-contents. This is done as follows, remember to change your user name and directory to what you used on your system:

Code: Select all

jaspermine$ ranlib /Volumes/MacFilez/Development/Blender/lib/darwin-6.1-powerpc/freetype/lib/libfreetype.a

jaspermine$ ranlib /Volumes/MacFilez/Development/Blender/lib/darwin-6.1-powerpc/ftgl/lib/libftgl.a

jaspermine$ ranlib /Volumes/MacFilez/Development/Blender/lib/darwin-6.1-powerpc/gettext/lib/libintl.a

jaspermine$ ranlib /Volumes/MacFilez/Development/Blender/lib/darwin-6.1-powerpc/jpeg/lib/libjpeg.a

jaspermine$ ranlib /Volumes/MacFilez/Development/Blender/lib/darwin-6.1-powerpc/ode/lib/libode.a

jaspermine$ ranlib /Volumes/MacFilez/Development/Blender/lib/darwin-6.1-powerpc/openal/lib/libopenal.a

jaspermine$ ranlib /Volumes/MacFilez/Development/Blender/lib/darwin-6.1-powerpc/png/lib/libpng.a

jaspermine$ ranlib /Volumes/MacFilez/Development/Blender/lib/darwin-6.1-powerpc/qhull/lib/libqhull.a


Code: Select all

jaspermine$ ranlib /Volumes/MacFilez/Development/Blender/lib/darwin-6.1-powerpc/sdl/lib/libSDL.a
And I think:

Code: Select all

jaspermine$ sudo ranlib /Volumes/MacFilez/Development/Blender/lib/darwin-6.1-powerpc/solid/lib/libsolid.a
There are several methods to compile Blender3D on Macintosh, this being the easiest. I ask that you explore and try the different methods. This method can be customized by editing the SConstruct file. On to the final step.

Step #4 Scons

If you've made it this far, Congratulations! This is the final step and errors past this point I will be unsure about as it worked on my machine. I take no responsibility, bla bla, so on, so forth, read the licenses, work in progress. Ok, just type scons already!!! Do this from Terminal:

Code: Select all

jaspermine$ cd /Volumes/MacFilez/Development/Blender/blender/
And hopefully last command:

Code: Select all

jaspermine$ scons
The End. Now getting your hands on the hottest new blender improvements and enhancements will be that much easier. Also by adding the capabilities of Fink, CVS client and Developer Tools you turn you Mac into a development powerhouse, so don't be shy and try adding that fluid solver algorithm you always wanted to see in Blender. ;)
Last edited by jsplifer on Wed Oct 06, 2004 3:09 am, edited 5 times in total.

Posts: 410
Joined: Mon Oct 14, 2002 4:32 am
Location: Sydney, Australia

Post by matt_e »

A side note, if you like to avoid using the command line (as I do), there is a reasonably good CVS GUI for Mac OS X available here: .

Posts: 0
Joined: Wed Feb 18, 2004 4:15 pm


Post by zbgump »

Will I be able to build Tuhopuu on OS X with this tutorial?


Posts: 0
Joined: Fri Jan 30, 2004 3:00 pm
Location: Paris, France

Post by krug »

The other solution being:

- get darwinports (fink-like software made by apple employees)
- install them
- type sudo port install blender or sudo port install blender +GameEngine


Posts: 35
Joined: Sun Dec 15, 2002 10:52 pm

Post by kid_tripod »

Is there somewhere where you can just download the 10.3 binaries?

Or am I being a muppet and the 10.2 ones will work?

EDIT: Now my Macs arrived, I know I'm a muppet!

Posts: 0
Joined: Wed Feb 18, 2004 4:15 pm

Post by zbgump »

krug wrote:The other solution being:

- get darwinports (fink-like software made by apple employees)
- install them
- type sudo port install blender or sudo port install blender +GameEngine

Are you still doing the Blender port? I didn't see it listed at Darwinports anymore.

Posts: 0
Joined: Mon Mar 22, 2004 1:13 am

Using Darwinports on Mac OS X 10.3.3 (Panther)

Post by mikew »

Re Krug's msg above:

Has anyone had success with building Blender on Mac OS X 10.3.3 (latest rev of Panther) using the darwinports mechanism?

I tried and it gets all the way to the final load of object files but appears to fail on a bad symbol reference to Apple's AudioToolbox.framework. (I suspect some symbolname changed in the latest release.)

Mike Wirth

PS: I can send console output if that would be useful.

PPS: I originally posted this note on the Test-builds topic, after which a "nasty-gram" :( appeared concerning the purpose of that topic. My apologies if I mis-posted. I'm new here :oops:

Posts: 0
Joined: Sun Mar 28, 2004 11:25 am

Post by V3nomX »

I'm not able to download the darwin lib, i typed the code and it tels me

cvs: gzip compression level must be between 1 and 9

? what can i do?


<edit> retried and worked...dunno what was the problem..tx anyway<edit>
The French Blender Portal

Post Reply