compiling with cygwin

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Post Reply
leon
Posts: 0
Joined: Mon Oct 20, 2003 7:14 am

compiling with cygwin

Post by leon » Fri Jan 30, 2004 12:05 pm

hi there,

I thought I'd take the next step with Blender and try compiling under Windows XP using Cygwin - I don't really know what I'm doing, so possibly this is a bad idea!

I'm following the instructions here:

http://projects.blender.org/viewcvs/vie ... cvs-markup

Immediately on doing the "make" command, I get the following result:

Code: Select all

$ make
====> make all in blender/dlltool
make[1]: *** No rule to make target `/cygdrive/c/graphics/programs/compiling/bf-
blender/blender/../lib/windows/gettext/lib/gnu_gettext.dll', needed by `/cygdriv
e/c/graphics/programs/compiling/bf-blender/blender/../lib/windows/gettext/lib/fr
eegettext.a'.  Stop.
make: *** [all] Error 1
Am i being hopelessly optimistic thinking I might get this working?!?

bjornmose
Posts: 0
Joined: Tue Nov 25, 2003 5:27 pm
Location: Denzenberg, could walk to Hölderling-Tower
Contact:

Post by bjornmose » Fri Jan 30, 2004 2:12 pm

cygwin compiles fine with me (less trouble than with MSVC6 some times)

did you really check out the LIB/windows module from CVS?
so bf-blender and LIB are two directories side by side.

"/lib/windows/gettext/lib/gnu_gettext.dll " there?



bjornmose

Hos
Posts: 185
Joined: Wed Oct 16, 2002 12:06 am

Post by Hos » Fri Jan 30, 2004 9:25 pm

Double check to make sure you did step 4 correctly (and that you
did it in the right directory ... you should have a directory with
2 items, blender/ and lib/).

Chris

leon
Posts: 0
Joined: Mon Oct 20, 2003 7:14 am

Post by leon » Sat Jan 31, 2004 1:42 am

:oops: :oops: :oops: I think I am too stupid to be doing this!!!

Having done step 4 like I should have done in the first place it works fine and Blender compiles!

Thanks all!

Post Reply