Any Progress YET?

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

bjornmose
Posts: 0
Joined: Tue Nov 25, 2003 5:27 pm
Location: Denzenberg, could walk to Hölderling-Tower
Contact:

Post by bjornmose » Fri Mar 26, 2004 4:49 pm

for a quick succes you can disable localization
in config.opts /* no linking to FTGL */

Code: Select all

USE_INTERNATIONAL = 'false'
bjornmose

guitargeek
Posts: 0
Joined: Thu Apr 24, 2003 12:54 am
Location: Greenville,IL USA

Post by guitargeek » Fri Mar 26, 2004 5:10 pm

The only one I did was for FTGL and that took care of the problem for me.

gabio
Posts: 0
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

Post by gabio » Sat Mar 27, 2004 12:27 am

i try to compile with scons since december and i still can't. Used msvc6 and .net framwork but 6 give ftgl error i can't get ride of(the link you'r talking about) and then jesterking told me there was a free msvc7 on the net, in .net framework, sadly this compiler isn't compatible with scons. at lease on my machine. it just don't find CL and all path is set. so i uninstalled msvc 6, .net framework, python, scons, cleaned the path, redownloadeed a fresh snapshot of the CVS entirely and... i'm on this now, i'll tell you if it work.

*edit*

ok i installed in order:
-msvc6
-msvc6 sp5
-framework . net
-framework.net sdk
-python 2.2.3
-scons .95 beta
-wincvs and snapshot lib and blender
-copy the quicktime sdk in lib/windows
on command line: (cmd)

Code: Select all

E:\src\blender\> sdkvars
seting vars...
E:\src\blender\>scons
that's all and it started compiling, though i need to have installed two msvc at a time, the only use of framework will lead you no where(for me it does).
all feature as in the cvs:
error: game engine . . je vas peter ma coche simonac.

jesterking is this error remember you something? you just merged the game engine i think..., well i'll try to compile without then, maybe it's not ready yet.

Code: Select all

KX_BlenderRenderTools.cpp
source\gameengine\Physics\Sumo\Fuzzics\include\SM_Scene.h(45) : fatal error C108
3: Cannot open include file: 'SOLID/SOLID.h': No such file or directory
scons: *** [E:\src\build\win32\source\gameengine\BlenderRoutines\KX_BlenderRende
rTools.obj] Error 2
scons: building terminated because of errors.
E:\src\blender>
game engine removed from sconstruct:
error: ftgl, ok it's an old one but why is the cvs still have this manifold code, evryone is bumping into this, why not fix it directly in the cvs???

international removed: a link warning...

Code: Select all

   Creating library blender.lib and object blender.exp
LINK : warning LNK4049: locally defined symbol "__iob" imported
scons: done building targets.
E:\src\blender>
result is a 3.39mo file, though i'll not use it since i wanted to try out the game engine, anyway it's still my first working scons build. :P

peterw
Posts: 0
Joined: Sat Jan 04, 2003 10:27 pm

Sucess with MSCV6!

Post by peterw » Sat Mar 27, 2004 2:22 am

Simon Clitherow did an update on the MSVC6 project files this morning.
With a new CVS download I got a good compile (working Game engine and all!) first go!

Thank you Simon, JesterKing, and most of all, Kestor for you great work.:lol:

Now to find what really works! (found a couple of things already)

Peter

havocsoft
Posts: 0
Joined: Thu Mar 18, 2004 9:42 pm

Post by havocsoft » Sat Mar 27, 2004 4:41 am

I got bf-blender to compile by disabling localization.
Scons says it dosn't know how to build target 'blender' when I try to compile tuhopuu2
-Compman
Webmaster, CompTeks.net
Founder, Admin, and Lead Developer, Havoc Software Productions

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Sat Mar 27, 2004 7:55 pm

gabio wrote: error: game engine . . je vas peter ma coche simonac.
I have not the faintest idea what that means. The only words I understand are the first four, "error..." (etc).
gabio wrote:

Code: Select all

KX_BlenderRenderTools.cpp
source\gameengine\Physics\Sumo\Fuzzics\include\SM_Scene.h(45) : fatal error C108
3: Cannot open include file: 'SOLID/SOLID.h': No such file or directory
scons: *** [E:\src\build\win32\source\gameengine\BlenderRoutines\KX_BlenderRende
rTools.obj] Error 2
scons: building terminated because of errors.
E:\src\blender>
You'll get this when you use for solid_include #extern/solid/include, or any other directory than #extern/solid (which contains the directory SOLID with the three necessary header files for compiling).
gabio wrote: game engine removed from sconstruct:
error: ftgl, ok it's an old one but why is the cvs still have this manifold code, evryone is bumping into this, why not fix it directly in the cvs???
This is an issue that needs to be corrected, I agree.

/jesterKing

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

updated msvc7 files.

Post by jesterKing » Mon Mar 29, 2004 10:18 am

http://www.letwory.org/tiki-download_file.php?fileId=39

Please test above tarball. Open it in your blender basedir. This will update the vcproj files in the intern directory (some renaming issues, where someone previously had used .a as library suffix). Also you'll find a new directory projectfiles_vc7 in the basedir.

First build the internal libraries by opening the solution for it in intern/make/msvc_7_0 and building build_install_all

When you're done with the internal libs, you open blender.sln from projectfiles_vc7/blender. You should make sure that blender is the active project and that you're building for release - the debug build needs still be checked.

I presuppose that all other auxiliary actions have been taken.

/jesterKing

havocsoft
Posts: 0
Joined: Thu Mar 18, 2004 9:42 pm

Post by havocsoft » Mon Mar 29, 2004 1:33 pm

build_install_all just says "build_install_all is up to date", even when I hit rebuild.
-Compman
Webmaster, CompTeks.net
Founder, Admin, and Lead Developer, Havoc Software Productions

bjornmose
Posts: 0
Joined: Tue Nov 25, 2003 5:27 pm
Location: Denzenberg, could walk to Hölderling-Tower
Contact:

Post by bjornmose » Mon Mar 29, 2004 1:37 pm

About the FTGL stuff i gave the answer myself here
http://www.blender.org/modules.php?op=m ... pic&t=3101
AFAIK Freetype by default should be a static lib rather than building a DLL.
in this case the dllimport/export branch should never be reached.

Most likly FTGL_LIBRARY_STATIC is not defined properly within the script.
Any module that includes ftgl.h must define this consistently.

bjornmose
extending defines in the win32 part of SConstruct
with defines += ['FTGL_LIBRARY_STATIC']
so defines look like:

Code: Select all

    defines = ['WIN32', '_CONSOLE']
    defines += ['WITH_QUICKTIME']
    defines += ['_LIB', 'USE_OPENAL']
    defines += ['FTGL_LIBRARY_STATIC']
    warn_flags = []
fixes the FTGL link error WITHOUT touching FTGL sources!

bjornmose

gabio
Posts: 0
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

Post by gabio » Mon Mar 29, 2004 4:05 pm

bravo tap tap...
hehehe

gabio
Posts: 0
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

Post by gabio » Tue Mar 30, 2004 2:42 am

just added the 3 header file in a new dir "solid" in extern/solid, and, ho a new bug... damn i must be cursed.

EDIT

Finaly corrected this problem. if it append, dont forget to update CVS...
Dhooo!

Code: Select all

KX_ConvertPhysicsObjects.cpp
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(428) : error C2039: 'm_imp
licitsphere' : is not a member of 'KX_ObjectProperties'
        source\gameengine\Ketsji\KX_ConvertPhysicsObject.h(65) : see declaration
 of 'KX_ObjectProperties'
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(429) : error C2039: 'm_bou
ndingbox' : is not a member of 'KX_ObjectProperties'
        source\gameengine\Ketsji\KX_ConvertPhysicsObject.h(65) : see declaration
 of 'KX_ObjectProperties'
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(429) : error C2228: left o
f '.m_extends' must have class/struct/union type
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(430) : error C2039: 'm_bou
ndingbox' : is not a member of 'KX_ObjectProperties'
        source\gameengine\Ketsji\KX_ConvertPhysicsObject.h(65) : see declaration
 of 'KX_ObjectProperties'
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(430) : error C2228: left o
f '.m_extends' must have class/struct/union type
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(431) : error C2039: 'm_bou
ndingbox' : is not a member of 'KX_ObjectProperties'
        source\gameengine\Ketsji\KX_ConvertPhysicsObject.h(65) : see declaration
 of 'KX_ObjectProperties'
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(431) : error C2228: left o
f '.m_extends' must have class/struct/union type
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(449) : error C2039: 'm_imp
licitsphere' : is not a member of 'KX_ObjectProperties'
        source\gameengine\Ketsji\KX_ConvertPhysicsObject.h(65) : see declaration
 of 'KX_ObjectProperties'
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(450) : error C2039: 'm_bou
ndingbox' : is not a member of 'KX_ObjectProperties'
        source\gameengine\Ketsji\KX_ConvertPhysicsObject.h(65) : see declaration
 of 'KX_ObjectProperties'
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(450) : error C2228: left o
f '.m_center' must have class/struct/union type
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(451) : error C2039: 'm_bou
ndingbox' : is not a member of 'KX_ObjectProperties'
        source\gameengine\Ketsji\KX_ConvertPhysicsObject.h(65) : see declaration
 of 'KX_ObjectProperties'
source\gameengine\Ketsji\KX_ConvertPhysicsObjects.cpp(451) : error C2228: left o
f '.m_extends' must have class/struct/union type
scons: *** [E:\src\build\win32\source\gameengine\Ketsji\KX_ConvertPhysicsObjects
.obj] Error 2
scons: building terminated because of errors.
E:\src\blender>
Here's the config

Code: Select all

elif sys.platform == 'win32':
    use_international = 'false'
    use_gameengine = 'true'
    use_openal = 'true'
    use_fmod = 'false'
    use_quicktime = 'true'
    use_sumo = 'true'
    use_ode = 'true'
    use_buildinfo = 'false'
    build_blender_dynamic = 'true'
    build_blender_static = 'false'
    build_blender_player = 'false'
    build_blender_plugin = 'false'
EDIT

Finaly corrected this problem. if it append, dont forget to update CVS...
Dhooo!

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Tue Mar 30, 2004 8:30 am

gabio wrote: Finaly corrected this problem. if it append, dont forget to update CVS...
I take it you are talking about tuhopuu2 cvs?

/jesterKing

gabio
Posts: 0
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

Post by gabio » Tue Mar 30, 2004 8:47 am

lol nop sorry jesterking i didn't touch tuhoppu2, mean update the local cvs on HD.

Good night

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Tue Mar 30, 2004 9:17 am

1) SCons does work fine for Windows from CVS, with the latest patch of Bjornmoose concerning the linking to FTGL, all compiling and linking issues have been resolved. There are still problems with the environmet variables, but I think this has been mentioned over at the SCons developers

2) The problem you were experiencing looks a lot like you were trying to build the ODE gameengine. Kester has modified some structs so that ODE code is now out of sync (ie. doesn't compile). The SConstruct in CVS already has solid as default enabled when building the gameengine.

/jesterKing

emack
Posts: 0
Joined: Fri May 23, 2003 1:53 am

Post by emack » Sun Apr 18, 2004 6:03 am

OK. I just tried this again with MSVC6 and tuhopuu2. I downloaded a fresh version of the tree from CVS, set all the include directories and library directories, and built the intern libraries without a problem.

When I try to compile the Blender project, I get the following error:

Linking...
LINK : fatal error LNK1181: cannot open input file "libopenalsoundsystem.lib"
Error executing link.exe.

blender.exe - 1 error(s), 0 warning(s)

I was unable to find this library file. I tried deleting the libopenalsoundsystem.lib from the list of external libraries, but that just causes the build to fail where the library is called.

jesterKing, could you or someone who understands the code better check to see that the current blender.dsw project file in tuhopuu2 will actually produce a blender.exe with the current CVS checkout? I need to know if I am doing something wrong, or if something else is broken.

Thanks,

Eliot

Post Reply