Page 1 of 1

Building with scons

Posted: Sun Mar 28, 2004 1:29 am
by ideasman
How do I build blender with scons under linux?
Im using the cvs if that makes any difference.

Posted: Sun Mar 28, 2004 1:46 am
by alien-xmp
1. Download and install scons from http://www.scons.org/download.html
2. From your blender source directory, run 'scons'
3. When scons says 'scons: done reading SConscript files.' hit Ctrl-C
4. Edit the config.opts file.
5. Run scons again.

Posted: Sun Mar 28, 2004 9:14 am
by ideasman
Thanks, got it working.

I was unable to build using the makefiles because it was trying to build the game engine in (looking for solid.h)- That I dont have.
Even though the game engine was disabled in the config files (as far as I could see anyway)

- Cam

Posted: Sun Mar 28, 2004 11:35 am
by jesterKing
ideasman wrote:I was unable to build using the makefiles because it was trying to build the game engine in (looking for solid.h)- That I dont have.
if you've checked out bf-blender CVS you _do_ have solid. Look in the extern directory. It has a solid directory with some subdirectories, among others SOLID, which contains three header files necessary for building: SOLID.h, SOLID_types.h and SOLID_broad.h

/jesterKing

Posted: Mon Mar 29, 2004 9:00 am
by Michaelv
scons is set up to build the gameengine, but the makefiles have lagged behind, I think that is being addressed though.

I'd add one step to alien-xmp's list, let scons run until it fails then address the config.opts file, scons may work without help. If it doesn't it will pick backup at the point of failure, and you'll know what to edit.

Which SCONS?

Posted: Mon Mar 29, 2004 10:21 am
by emack
Do you need the full SCONS package, or can you use the scons-local package on the download page?

Posted: Mon Mar 29, 2004 10:32 am
by jesterKing
You should be able to use the scons-local package - but that is as full as the full package.

/jesterKing

Posted: Mon Mar 29, 2004 11:49 am
by Michel
ideasman wrote:Even though the game engine was disabled in the config files (as far as I could see anyway)
Hi,

true, the game engine is disabled by default in the config.opts file. To enable it, just set BUILD_GAMEENGINE='true' and USE_PHYSICS='solid'.
If you want sound enabled in the game engine, set USE_OPENAL='true'. Note that you may have to update some library linking when using OpenAL. The default libs and libpath for OpenAL are very minimal - but work on my system.

With regards,
Michel