Page 1 of 1

compiling GamePlayer

Posted: Sun Apr 17, 2005 6:05 pm
by Doc_Holiday
I made my first 2.36 Build with Cygwin and Win2k. All fine till now. ;) But how do i compile the GamePlayer? All i get is the Blender.exe.
Thanx, Doc

Posted: Sun Apr 17, 2005 7:04 pm
by Sutabi
The gameblender in built into the .exe... there is an option you can set in userdef.mk but I forgot the option =_= sorry. but search the source for any text of GamePlayer you might find the definition in there

Posted: Sun Apr 17, 2005 10:32 pm
by z3r0_d
# To build blender without having to build the plugin, etc
#export NAN_JUST_BLENDERDYNAMIC=true

... that is all I could find, it used to be built by default but isn't any more

Posted: Sun Apr 17, 2005 11:02 pm
by Doc_Holiday
Ok, made a 'user-def.mk' with export NAN_JUST_BLENDERDYNAMIC=true ... no, won't work. :( Cygwin give an Error and breaks:

Code: Select all

cl: not found
make[5]: *** [/cygdrive/c/bf-blender/blender/obj/windows/gameengine/GamePlayer/n
etscape/src/Blender3DPlugin.o] Error 127
Do i need something special?

Posted: Mon Apr 18, 2005 3:02 am
by z3r0_d
I compile in cygwin

my user-def.mk has only two non-commented lines

Code: Select all

export FREE_WINDOWS=true
export CFLAGS += -DGAMEBLENDER=1
the second one is probably redundant, but the blenderplayer seems to be built

I'm trying a "make clean all" now to be sure. config.opts [scons build system] is a lot more clear on the build settings than user-def.mk

edit:
blenderplayer isn't built, I'm not sure how I did it anymore

Posted: Tue Apr 19, 2005 10:00 am
by Doc_Holiday
Nobody knows that? :shock: I'm confused. If there is a official Release, how do they get the GamePlayer :?:
Doc

Posted: Tue Apr 19, 2005 2:04 pm
by SirDude
To build without the gameplayer you want to set:
export NAN_JUST_BLENDERDYNAMIC=true
export NAN_NO_OPENAL=true

or just set: export NAN_NO_KETSJI=true

So to build the gameplayer you want to make sure those all are not set.

Posted: Wed Apr 20, 2005 6:04 pm
by Doc_Holiday
No, i don't get it to work. I give up! :(