Page 1 of 1

compile error with SCons

Posted: Thu May 12, 2005 4:22 pm
by johannes
Hi,

I try to build Blender on my new linux system. I get this error:

Code: Select all

scons: Reading SConscript files ...
targets =  []
arguments =  {}
Using config file: config.opts
externs...
scons: done reading SConscript files.
scons: Building targets ...
gcc -pipe -funsigned-char -O2 -Wall -W -DGAMEBLENDER=0 -DNDEBUG -DBUILD_TIME='"16:07:12"' -DBUILD_DATE='"2005-05-12"' -DBUILD_TYPE='"dynamic"' -DNAN_BUILDINFO -DBUILD_PLATFORM='"linux2"' -I/usr/include -I/usr/X11R6/include -c -o /home/johannes/Development/build/linux2/source/creator/dynamic_buildinfo.o source/creator/buildinfo.c
-pipe -funsigned-char -O2 -Wall -W -DGAMEBLENDER=0 -DNDEBUG -Iintern/guardedalloc -I/home/johannes/Development/build/linux2/source/blender/blenlib -Isource/blender/blenlib -Isource/blender/blenlib -I/home/johannes/Development/build/linux2/source/blender/makesdna -Isource/blender/makesdna -Isource/blender/makesdna -I/home/johannes/Development/build/linux2/source/blender/blenkernel -Isource/blender/blenkernel -Isource/blender/blenkernel -I/home/johannes/Development/build/linux2/source/blender/imbuf -Isource/blender/imbuf -Isource/blender/imbuf -I/home/johannes/Development/build/linux2/source/blender/include -Isource/blender/include -Isource/blender/include -I/home/johannes/Development/build/linux2/source/blender/render/extern/include -Isource/blender/render/extern/include -Isource/blender/render/extern/include -I/home/johannes/Development/build/linux2/source/blender/render/intern/include -Isource/blender/render/intern/include -Isource/blender/render/intern/include -c -o /home/johannes/Development/build/linux2/source/blender/yafray/intern/yafray_Render.o source/blender/yafray/intern/yafray_Render.cpp
sh: - : invalid option
scons: *** [/home/johannes/Development/build/linux2/source/blender/yafray/intern/yafray_Render.o] Error 1
scons: building terminated because of errors.
Any ideas what I have done wrong / what is missing


Thanks

Posted: Thu May 12, 2005 7:17 pm
by stiv
/me guesses:
a) no c++ compiler installed ( g++ in your case )
b) no definition for HOST_CXX. look in your config.opts file. usually caused by a).

Posted: Thu May 12, 2005 7:52 pm
by johannes
No I have a compiler installed. BTW It works now. I forgot to install some libs. The list of needed libs in the docs is quite incomplete! But it still doesn't work with make!?! Thanks anyhow!