SOLVED - Problems building blender - anybody with

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Fri Mar 26, 2004 11:36 pm

SOLVED - Problems building blender - anybody with

Post by fakeplasticdreams »

I have not been able to build blender lately either the 2.37a source or the CVS.

I have been upgrading some things, like to KDE3.4.2 and to instead of X86free (or something like that).

It seems like the problem is in blenderplayer, but I don't know for sure. I am going to do more testing.

Has anybody else upgraded to these? And if so, can you build blender still?

Thanks guys, Any help would be greatly appreciated.

Edit: Ok, I tried making Blenderplay to False in SConstruct, and it quit much sooner with this output (similar to what I got before, just sooner)

Code: Select all

cory@1[blender]$ scons
scons: Reading SConscript files ...
targets =  []
arguments =  {}
Using config file: config.opts
Including El'Beem Fluid Simulation...
scons: done reading SConscript files.
scons: Building targets ...
gcc -pipe -funsigned-char -O2 -Wall -W -DGAMEBLENDER=1 -DUSE_SUMO_SOLID -DNDEBUG -DBUILD_TIME='"22:10:45"' -DBUILD_DATE='"2005-09-26"' -DBUILD_TYPE='"dynamic"' -DNAN_BUILDINFO -DBUILD_PLATFORM='"linux2"' -I/usr/include -I/usr/X11R6/include -c -o /home/cory/src/blender-src/build/linux2/source/creator/player_buildinfo.o source/creator/buildinfo.c
gcc -Xlinker -export-dynamic -pthread -o blenderplayer /home/cory/src/blender-src/build/linux2/source/creator/player_buildinfo.o -L/home/cory/src/blender-src/build/linux2/lib -Llib -L/usr/lib/python2.3/config -L/usr/local/lib -L/usr/lib -L/usr/lib -L/usr/lib -L/usr/lib -L/usr/X11R6/lib -lGPG_ghost -lGPC_common -lblender_readblenfile -lblender_img -lblender_blenkernel -lblender_blenloader -lblender_blenpluginapi -lblender_imbuf -lblender_avi -lblender_blenlib -lblender_makesdna -lblender_kernel -lblender_GHOST -lblender_STR -lblender_guardedalloc -lblender_CTR -lblender_MEM -lblender_MT -lblender_BMF -lsoundsystem -lfreetype -lz -lblender_FTF -lextern_ftgl -lfreetype -lz -lKX_blenderhook -lKX_converter -lPHY_Dummy -lPHY_Physics -lKX_ketsji -lSCA_GameLogic -lRAS_rasterizer -lRAS_OpenGLRasterizer -lblender_expressions -lSG_SceneGraph -lblender_MT -lKX_blenderhook -lKX_network -lblender_kernel -lNG_network -lNG_loopbacknetwork -lPHY_Sumo -lPHY_Physics -lblender_MT -lextern_solid -lextern_qhull -lblender_blenkernel_blc -lblender_LOD -lsoundsystem -lblender_python -lpython2.3 -lSDL -lpthread -lpng -ljpeg -lz -lm -lutil -lstdc++ -lGL -lGLU
/usr/bin/ld: warning:, needed by /usr/lib/, may conflict with
/usr/lib/libGL.a(glxcmds.o): In function `glXGetMscRateOML':
: undefined reference to `XF86VidModeQueryVersion'
/usr/lib/libGL.a(glxcmds.o): In function `glXGetMscRateOML':
: undefined reference to `XF86VidModeGetModeLine'
collect2: ld returned 1 exit status
scons: *** [blenderplayer] Error 1
scons: building terminated because of errors.
Last edited by fakeplasticdreams on Wed Sep 28, 2005 9:30 pm, edited 1 time in total.

Posts: 0
Joined: Wed Jul 23, 2003 4:31 pm

Post by kidb »

Missing packages. libxxf86vm-dev developer packages and/or xlibs-static-dev if you have a debian system.

Posts: 0
Joined: Fri Mar 26, 2004 11:36 pm

Post by fakeplasticdreams »

I installed those (already had one of them) but still having the same error.

Maybe I will try to go back to xfree86 (if i can)

Any other ideas?


Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv »

An undefined reference means the library in question does not exist on your system in a usable form or it is not in the compilers path or lib list.

Try googling for "undefined reference to `XF86VidModeGetModeLine'". It turns up about 249 hits and tells you what you may need to add.

Posts: 0
Joined: Tue Feb 25, 2003 2:37 pm

Post by ideasman »

Thats odd, I have never had that issue and use, though perhaps I have the library from when I was using xfree86-

Good luck with compiling.

- Cam

Posts: 0
Joined: Fri Mar 26, 2004 11:36 pm

Post by fakeplasticdreams »

Ok, well, I think I got this working now.

The problem was that when I upgraded something, one of my symbolic links ( was left linking to a non-existant file. So I fixed that, and now the 2.37a source compiles.

The CVS still didn't compile, but that seems like another issue.

Thanks for all your help. Sorry if I am posting rather noobish questions. I am still learning all this.

Post Reply