Page 1 of 1

Render this window and all layer key doesn't work - updated

Posted: Tue Sep 27, 2005 1:56 pm
by teragone
Hi,

I compile Blender 2.37a myselft on Ubuntu (AMD64) with scons.

All is working well except that render this window is all black (but F12 work).

Also, the ~ and ` keys to enable and disable all the layers doesn't work.

Any ideas ?

Thanks

Update :

Can a Blender developer could tell me which source file are involve in the problems specified. I have done a search but no success.

The bug report have been closed because i don't use the official release.

Posted: Tue Sep 27, 2005 5:01 pm
by gabio
me too.
Bug tracker then.
it's in the menu on your left.

Posted: Tue Sep 27, 2005 5:42 pm
by teragone
I have submit a bug for each problem.

Update

Posted: Wed Sep 28, 2005 2:08 pm
by teragone
See first comment for the update.

Posted: Wed Sep 28, 2005 3:08 pm
by z3r0_d
do builds that you didn't make [like from the testing build forum] have the same issue?

Posted: Wed Sep 28, 2005 3:34 pm
by teragone
I have try these 2 versions :

blender-2.37a-linux-glibc2.3.5-x86_64.gcc4.pyth2.4

blender-linux-glibc2.3.5-20050926

But none of them work, They don't start at all.

Posted: Wed Sep 28, 2005 4:58 pm
by kidb
teragone wrote:I have try these 2 versions :
blender-2.37a-linux-glibc2.3.5-x86_64.gcc4.pyth2.4
x86_64 version. This is compiled on my testbuild-linuxtest-testsystem.
teragone wrote:blender-linux-glibc2.3.5-20050926
i386 version.

Latest cvs-builds, so they may actual have problems.
teragone wrote:But none of them work, They don't start at all.
No console output?
what does strace say?

Posted: Wed Sep 28, 2005 7:42 pm
by teragone
Don't remember exactly which one, but it's a missing library.

But I find a workaround for the layer problem.

I added a line in GHOST_SystemX11.cpp in convertXkey function:

GXMAP(type,XK_numbersign, GHOST_kKeyAccentGrave);

The ` key is mapped to # on my keyboard, Maybe because i have set a french canadian keyboard. But even if a use a USA layout,I had the problem.

Now with the modification all is working well with both layout (USA and french canadian).

What is strange is that the Blender text editor map correctly the ` and ~ keys without the modification.