Latest linux CVS compile (20/10/05) error

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Napoleon
Posts: 0
Joined: Tue Jan 27, 2004 6:08 pm

Post by Napoleon » Thu Oct 27, 2005 11:16 am

Hi jesterKing,

I Dual boot windows and Linux. This problem is on linux. I use Archlinux with gcc 4 and scons.

About the "cvs update -P" command, i am not updating a daily tar tarball as a matter of fact i followed the instruction found at
http://www.blender3d.com/cms/Getting_Sources.134.0.html and http://projects.blender.org/cvsx/?group_id=9. I did a cvs checkout.

Thanks

kidb
Posts: 0
Joined: Wed Jul 23, 2003 4:31 pm
Contact:

Post by kidb » Thu Oct 27, 2005 11:27 am

Napoleon wrote: with gcc 4
you should use this patch which works for me.
http://blendertestbuilds.de/index.php?d ... C-4-Patch/
(stolen from Debian bug tracker).
But i think cvs is broken for the moment.

Napoleon
Posts: 0
Joined: Tue Jan 27, 2004 6:08 pm

Post by Napoleon » Thu Oct 27, 2005 1:34 pm

how do i apply the patch please?

kidb
Posts: 0
Joined: Wed Jul 23, 2003 4:31 pm
Contact:

Post by kidb » Thu Oct 27, 2005 1:38 pm

Napoleon wrote:how do i apply the patch please?
in your blender dir, where you type scons:
patch -p1 < path/to/patch/nameof.patch
Last edited by kidb on Thu Oct 27, 2005 3:58 pm, edited 1 time in total.

raphael
Posts: 4
Joined: Mon May 26, 2003 10:18 pm
Location: france
Contact:

Post by raphael » Thu Oct 27, 2005 3:56 pm

jesterking, the whole output is quite long, but scons complains because of a missing file (SOLID.h) :

source/gameengine/Physics/Sumo/Fuzzics/include/SM_Scene.h:45:25: SOLID/SOLID.h : Aucun fichier ou répertoire de ce type ( missing file )
In file included from source/gameengine/Physics/Sumo/SumoPhysicsController.h:36,

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Thu Oct 27, 2005 4:33 pm

raphael, are you sure you made the change to config.opts, as written before? That is, change for gameengine from bullet to solid. Also, do a

Code: Select all

scons clean
/Nathan

Napoleon
Posts: 0
Joined: Tue Jan 27, 2004 6:08 pm

Post by Napoleon » Fri Oct 28, 2005 8:46 am

It now seems to a one man crusade to get this compile to happen on linux. Well latest is i applied the gcc4 patch which seemed to go well then, scons clean and scons rlease,> there were still errors however.

BTW i use the module lib/linux-glibc2.3.1-i386 since i have glibc 2.3.5 installed on my system. Is that any help? Has anybody been able to build a recent linux build at all?

Strange ebough there has not been a linux testing build for a while could it be that you guys are all having problems? About the "bullet" and "solid" option for the gameengine, If its causes problems for linux builders using scons, shouldn't that be looked into as i presume scons is the new more favoured build system?

It will help me please if soneone who has successfully build the latest cvs build, list the related softwares and versions, compilers etc that they use and also any patches if any they have to add to make it happen please.

Have a great day. God bless.

phti
Posts: 0
Joined: Thu Jun 23, 2005 9:55 pm
Contact:

mac os x compiling now ok

Post by phti » Fri Oct 28, 2005 10:47 am

hi,
on mac os x (with gcc 3.3), yesterday I updated from latest cvs, then changed config.opts in game engine physics to solid from bullet, then scons clean and then compiling with scons, and it worked.

fakeplasticdreams
Posts: 0
Joined: Fri Mar 26, 2004 11:36 pm

Post by fakeplasticdreams » Fri Oct 28, 2005 5:39 pm

I also have not been able to compile for linux either.

I changed the SConstruct file and config.opts file to set the game engine to false, but I still get compile errors. I have to check my output again (cause my wife turned off my computer before I could check it :roll: ) but either the game engine is still trying to be built, or there is another problem that is not in the game engine that is causing compile errors.

If anyone has any insight, it would be appreciated.

raphael
Posts: 4
Joined: Mon May 26, 2003 10:18 pm
Location: france
Contact:

Post by raphael » Fri Oct 28, 2005 7:45 pm

hi,

I downloaded a fresh CVS, and turn GE from bullet to solid in config.opts, but ... it did not worked...

I can only compile blender if i disable GameEngine.

fakeplasticdreams
Posts: 0
Joined: Fri Mar 26, 2004 11:36 pm

Post by fakeplasticdreams » Fri Oct 28, 2005 8:08 pm

raphael wrote:hi,

I downloaded a fresh CVS, and turn GE from bullet to solid in config.opts, but ... it did not worked...

I can only compile blender if i disable GameEngine.
How do you disable to game engine? I have tried, but it seems like I am missing something. I edited SConstruct and config.opts and set game engine to false. Is there anything else I need to do?

raphael
Posts: 4
Joined: Mon May 26, 2003 10:18 pm
Location: france
Contact:

Post by raphael » Fri Oct 28, 2005 8:23 pm

hi,

perhaps you forgot to disable the player too. It uses the game engine.

in config.opts
BUILD_BLENDER_PLAYER = 'false'

fakeplasticdreams
Posts: 0
Joined: Fri Mar 26, 2004 11:36 pm

Post by fakeplasticdreams » Fri Oct 28, 2005 10:24 pm

That would be it. Thanks! :D

I had no idea that would do that. I'll give that a try, and hopefully get it to compile.

Thanks again.

kidb
Posts: 0
Joined: Wed Jul 23, 2003 4:31 pm
Contact:

Post by kidb » Sat Oct 29, 2005 8:44 pm

Solved by the developers, compiles now with scons and/or make.
x86_64 build:
http://www.blendertestbuilds.de/index.p ... /20051029/

Napoleon
Posts: 0
Joined: Tue Jan 27, 2004 6:08 pm

Post by Napoleon » Sat Oct 29, 2005 9:50 pm

Hi kidb,

How recent is the cvs sources you used cause i had a fresh download from about 4 hrs ago and i am only able to compile when i disable gameengine.

*edit* I confirm that compilation works with a fresh cvs checkout without disabling the gameengine. Thanks to all the devs :D

Post Reply