Compiling errors with visual studio

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Post Reply
LeeQid
Posts: 0
Joined: Sun Jan 09, 2005 10:30 pm

Compiling errors with visual studio

Post by LeeQid »

Here's what the compiler says:

Code: Select all

------ Rebuild All started: Project: OpenALSoundSystem, Configuration: Blender Release Win32 ------

Deleting intermediate files and output files for project 'OpenALSoundSystem', configuration 'Blender Release|Win32'.
Compiling...
SND_SDLCDDevice.cpp
c:\blenderdev\blender\intern\SoundSystem\sdl\SND_SDLCDDevice.h(35) : warning C4091: 'typedef ' : ignored on left of 'SDL_CD' when no variable is declared
SND_OpenALDevice.cpp
c:\blenderdev\blender\intern\SoundSystem\openal\SND_OpenALDevice.h(38) : warning C4091: 'typedef ' : ignored on left of 'SDL_CD' when no variable is declared
..\..\..\sdl\SND_SDLCDDevice.h(35) : warning C4091: 'typedef ' : ignored on left of 'SDL_CD' when no variable is declared
\blenderdev\blender\intern\SoundSystem\openal\SND_OpenALDevice.cpp(234) : error C2065: 'ALCcontext' : undeclared identifier
\blenderdev\blender\intern\SoundSystem\openal\SND_OpenALDevice.cpp(234) : error C2059: syntax error : ')'
\blenderdev\blender\intern\SoundSystem\openal\SND_OpenALDevice.cpp(342) : error C2059: syntax error : ')'
\blenderdev\blender\intern\SoundSystem\openal\SND_OpenALDevice.cpp(342) : error C3861: 'ALCcontext': identifier not found, even with argument-dependent lookup

Build log was saved at "file://c:\blenderdev\build\msvc_7\intern\soundsystem\openal\BuildLog.htm"
OpenALSoundSystem - 4 error(s), 3 warning(s)
Now how can I fix this?[/code]

Post Reply