Page 1 of 1

Problems with Intel P4 HT and Blender 2.41

Posted: Mon Mar 13, 2006 12:05 am
by rommel
Hi everybody:

I have been using Blender for some months now.

I used Blender 2.37 which works great in my computer

But when I upgrade to Blender 2.41 things went wrong, the new Blender is too slow.

I made some tests and I notice that 2.37 uses all my processor (it is a Intel P4 Multithread)

But the new 2.41 only uses only half of it.

My system is a Sager N9880:

Operating System: Microsoft Windows XP Service Pack 2 (Build 2600)
Processor: Intel(R) Pentium(R) 4 CPU 3.80GHz EM64T with HT Technology.
Type: GenuineIntel x86 Family 15 Model 4 Stepping 3 (~ 3800 MHz)
(The OS see it as two processors)

RAM: 2046MB

Video Card: NVIDIA GeForce Go 6800 Ultra
Driver Version: 7.6.5.0

DirectX Version: 9.0c

I had to go back to 2.37 :cry:

I really appreciate any help with this issue.

Thanks

Posted: Mon Mar 13, 2006 12:44 am
by mfoxdogg
blender 2.41 is not 64bit compatable, there is a 64bit build somewhere in this forum , try that

Problems with Intel P4 HT and Blender 2.41

Posted: Mon Mar 13, 2006 2:00 am
by rommel
Yes, I already read about the 64bit version, but my OS is 32bits.

I guess I can not use the 64bits version in my computer running Windows XP Pro 32bits edition, right??

Thanks for your reply.

Posted: Mon Mar 13, 2006 2:35 pm
by Caronte
Push the [Threads] button in the F10 panel ;)

Posted: Mon Mar 13, 2006 8:39 pm
by rommel
Thank you all for your answers.

I tried the F10 threads button but it doesn’t make a difference.

2.41 is slow for everything, no just rendering. Even for rotating and so.

For instance, the model I’m using is a ship with this statistics:

surfaces: 15304 vertices: 8970

in 2.37 I can rotate, move, drag, etc the model with out any problem and in real time, but in 2.41 it takes a long while to even rotate the model (more than 5 secs even more!!!)

I run the benchmark, these are the results:

2.41 >>> 2645 iterations
2.38 >>> 7671 iterations


Using 2.38 the processor goes all the way to 100% usage when doing some heavy stuff, but in 2.41 the processor never goes beyond 50%.

I think that this release is not making use of multithreads capabilities of new processors as the previous one did (2.37).


(Sorry about my English, it is not my native language)