SOC Sculpt Build errors

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Post Reply
JA-forreal
Posts: 0
Joined: Sat Mar 22, 2003 10:45 pm

SOC Sculpt Build errors

Post by JA-forreal »

I just finished building a SOC Sculpt build on Ubuntu Dapper. It seemed to compile ok. When I ran it in a terminal I got this error report-


Code: Select all

Compiled with Python version 2.4.
Checking for installed Python... got it!
X Error of failed request:  BadDevice, invalid or uninitialized input device
  Major opcode of failed request:  146 (XInputExtension)
  Minor opcode of failed request:  3 (X_OpenDevice)
  Serial number of failed request:  24
  Current serial number in output stream:  24

JA-forreal
Posts: 0
Joined: Sat Mar 22, 2003 10:45 pm

Post by JA-forreal »

I chmod +x 'd the executable but it won't run. Am I missing something?

kidb
Posts: 0
Joined: Wed Jul 23, 2003 4:31 pm
Contact:

Re: SOC Sculpt Build errors

Post by kidb »

Code: Select all

X Error of failed request:  BadDevice, invalid or uninitialized input device
  Major opcode of failed request:  146 (XInputExtension)
Edited the wrong post. Here should be something like dpkg -l libxi. But it is wrong anyway.
Last edited by kidb on Wed Aug 02, 2006 11:30 pm, edited 3 times in total.

JA-forreal
Posts: 0
Joined: Sat Mar 22, 2003 10:45 pm

Post by JA-forreal »

kidb I got this in the console-

Code: Select all

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
ii  libxi-dev      1.0.0-0ubuntu3 X11 Input extension library (development hea
ii  libxi6         1.0.0-0ubuntu3 X11 Input extension library
ii  libxi6-dbg     1.0.0-0ubuntu3 X11 Input extension library (debug package)
un  libxine-extrac <none>         (no description available)
ii  libxine-main1  1.1.1+ubuntu2- the xine video/media player library, binary
un  libxine1       <none>         (no description available)
un  libxine1c2     <none>         (no description available)
ii  libxinerama1   1.0.1-0ubuntu2 X11 Xinerama extension library
What does this mean exactly? And what is the relationship to by build of Blender-Sculpt not running? Thanks.

kidb
Posts: 0
Joined: Wed Jul 23, 2003 4:31 pm
Contact:

Post by kidb »

There is support for an Xinput-Device (tablet) in the latest code. I unplugged my tablet and get now the same error. Solution: Buy a tablet. :-)
I will look if i can add spaceball-support, but only for linux.

Post Reply