Subdivided faces not visible in object mode?

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
mr.burns
Posts: 0
Joined: Sun Dec 31, 2006 2:21 pm

Subdivided faces not visible in object mode?

Post by mr.burns » Wed Jan 03, 2007 3:30 pm

Hello,

I have a mesh plane, a simple square and in edit mode I have subdivided it by 2, now I have 4 squares.
If I switch back to object mode I still se only one face instead of four.
How can I make the 4 faces visible / selectable in object mode as well?

I need this to export it. Exporting my square shows only one square in the exported file, not 4 which I need.

Any help is highly appreciated,

Thanks!

blendmt
Posts: 0
Joined: Wed Jan 03, 2007 12:52 pm

Post by blendmt » Wed Jan 03, 2007 4:18 pm

To view the subdivided plane in object mode just enable the little button with the grid ("Enable modifier during interactive display") which is just near "Subsurf" in the Modifiers panel (the same place where you set subdiv levels, etc.).

Before you can export the subdivided object just click "Apply" in the "Subsurf" section so that it modifies the actual geometry.

mr.burns
Posts: 0
Joined: Sun Dec 31, 2006 2:21 pm

Thanks, but...

Post by mr.burns » Wed Jan 03, 2007 4:42 pm

Hello blendmt,

thanks for your reply but I cannot find the 'button with the grid' you mentioned. I am very new to blender, sorry.
I use Blender 2.42a, in Edit Mode in the Modifiers panel I have only an 'Add Modfier' button. There is no 'subsurf', and by the way I used subdivide under 'Mesh tools' and not subsurf (by adding a modifier), if this is important!
And I don't understand what you mean saying 'Enable modifier during interactive display'.
And can you please be more detailed with:
Before you can export the subdivided object just click "Apply" in the "Subsurf" section so that it modifies the actual geometry.

Thanks for further support!

blendmt
Posts: 0
Joined: Wed Jan 03, 2007 12:52 pm

Post by blendmt » Wed Jan 03, 2007 5:23 pm

Hmm, ignore my previous post then cause I assumed you were using the "Subsurf" modifier.

I've no idea why the wireframe doesn't show up properly in object mode. However I managed to export the subdivided plane with no problems in .lwo format (Lightwave).

Good luck

blendmt
Posts: 0
Joined: Wed Jan 03, 2007 12:52 pm

Post by blendmt » Wed Jan 03, 2007 5:32 pm

After some experimentation it seems that blender shows just the "outline" of the object when in object mode. I'm not sure if this default behaviour can be changed.

fobsta
Posts: 0
Joined: Sat Jun 12, 2004 11:21 pm

Post by fobsta » Wed Jan 03, 2007 11:08 pm

In Blender 2.4a with a poly mesh selected, press f9 to go to edit mode and press the 'slower draw' button in mesh tab. Then press f7 for object mode and in the draw tab pressed 'shaded' and then press 'wire'.

For exporting simple meshes try the Wavefront Oject .obj format. It should be relatively pain free.

mr.burns
Posts: 0
Joined: Sun Dec 31, 2006 2:21 pm

Thanks, but...

Post by mr.burns » Thu Jan 04, 2007 10:47 am

Hello fobsta,

thanks for your help, I selected the mesh in Edit Mode and pressed the SlowerDr button, but if I then press F7, as you suggested, I activate the 'Physics button' (still in Edit mode), so I are not in object mode as you wrote!
As far as I know to switch between Edit Mode and Object Mode one should use the TAB key.
After switching to object mode (using the TAB key) I cannot find a tab named Draw. :-(
So could you please give me some hints how to achieve what you mentioned?

Thanks for further support!

mr.burns
Posts: 0
Joined: Sun Dec 31, 2006 2:21 pm

fobsta

Post by mr.burns » Thu Jan 04, 2007 11:01 am

Hello fobsta,

I found It now what you mentioned, but the subdivided faces ars still not visible in object mode :-(
You can try with a simple plane as follows:

1. In object mode create a new plane (SPACE --> Add --> Mesh --> Plane)
2. You are in Edit Mode now, so press F9 for the Editing window type
3. Under the Mesh tools tab press 'Subdivide' once
4. Then do what you suggested:
4a. In the Mesh tools tab, press SlowerDr
4b. Go to Object Mode using the Tab key
4c. Press F7 to get the Object window type (may you must press twice to see the Draw tab)
4d. Press shaded as Drawtype and then Wire in the last buttom column

5. Watch the mesh, it still does not show the subdivided meshes!

Any further ideas???

blendmt
Posts: 0
Joined: Wed Jan 03, 2007 12:52 pm

Post by blendmt » Thu Jan 04, 2007 5:32 pm

Hi, try this: Go to object mode, select your plane and click on the SlowerDraw button. Note that the result can only be seen if your viewport shading is set to Wireframe.

fobsta
Posts: 0
Joined: Sat Jun 12, 2004 11:21 pm

Post by fobsta » Thu Jan 04, 2007 5:41 pm

as blendmt has mentioned you were pressing the 'slower draw' button when you were in edit mode.

You should press it when the poly mesh is in object mode

hope this helps

blendmt
Posts: 0
Joined: Wed Jan 03, 2007 12:52 pm

Post by blendmt » Thu Jan 04, 2007 6:20 pm

In the latest release they've changed the procedure (to the better). So I suppose it would be a good idea to download RC1 as its UI has changed a bit. I would say it's more context sensitive now.

fobsta
Posts: 0
Joined: Sat Jun 12, 2004 11:21 pm

Post by fobsta » Thu Jan 04, 2007 7:40 pm

You'll probably be interested in this thread I have started

http://blenderartists.org/forum/showthr ... post782605

mr.burns
Posts: 0
Joined: Sun Dec 31, 2006 2:21 pm

Thanks to all, that helped!

Post by mr.burns » Thu Jan 04, 2007 8:13 pm

Hello fobsta,

the link you provided finally presented the solution.
It has only to do with the 'All Edges' button in Edit Mode / Mesh Tools 1 Tab.
If this is enabled all edges are shown, also in object mode now!.

I hope I can also export it now, but this I can test only tomorrow!

Thanks a lot for helping me!

Post Reply