Edit-mode tools causing extreme lag - help please?

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
Clean3d
Posts: 0
Joined: Fri May 09, 2008 11:16 pm

Edit-mode tools causing extreme lag - help please?

Post by Clean3d » Sat May 10, 2008 1:10 am

I'm using Blender 2.45 on Ubuntu Hardy Heron, and recently the move, rotate, and scale features in edit mode have all been causing long lags. For instance, I select a vert and hit "G"... I can move the vertex a short distance and then Blender will freeze for a few seconds, not letting me use my mouse or keyboard.

So far, I've only noticed this in one .blend file that I'm working on (I can upload it if necessary), and it doesn't happen *every* time I use these tools.

Can someone please tell me why this is happening and how I can avoid/fix it?

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Sat May 10, 2008 12:06 pm

Try the static binaries from our website. If they work fine, then you have a driver problem. What it exactly is, I don't know.

/Nathan

Clean3d
Posts: 0
Joined: Fri May 09, 2008 11:16 pm

Post by Clean3d » Sat May 10, 2008 6:16 pm

Thanks for the reply, Jesterking. I tried the Linux x86-32 build from blender.org and the problem persists. I've also noticed this problem in another file I'm working on, so I don't think it's some crazy thing I did with the one.

KrisBerg
Posts: 0
Joined: Sun May 25, 2008 10:04 pm

Post by KrisBerg » Sun May 25, 2008 10:23 pm

I also have the same problem as Clean3d. I run Ubuntu Hardy Heron 8.04, Blender 2.46 32bit. It's a Dell Laptop Inspiron 1720 with Nvidia graphics card.

Edit: Rgiht after posting my problem, I think I found a solution to it :) I install Nvidia Settings using:

Code: Select all

sudo apt-get install nvidia-settings

Code: Select all

sudo nvidia-settings
Then I checked the "Sync to VBlank", and I also put the "Image Settings" to "High Performance".

I have NO idea if this is actually related to the "lagging" itself and Blender, but it seems like it made the problem go away.

Good luck for those of you that this doesn't help.

Clean3d
Posts: 0
Joined: Fri May 09, 2008 11:16 pm

Post by Clean3d » Sun May 25, 2008 11:12 pm

Thanks KrisBerg! That seems to have fixed it. :)

(p.s. After talking to a friend, I'm not sure I was using the static builds from Blender.org. I simply used the ones from the download page. :/)

Clean3d
Posts: 0
Joined: Fri May 09, 2008 11:16 pm

Post by Clean3d » Mon May 26, 2008 6:35 pm

Argh, it turns out that didn't solve the problem after all. Could someone give me a link to the Linux i386 static build, so I can be sure I'm testing with the right one?

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Tue May 27, 2008 5:28 am


Star_Ranger4
Posts: 0
Joined: Tue May 27, 2008 10:04 pm

Post by Star_Ranger4 » Tue May 27, 2008 10:23 pm

I would have to expect that this is more a function of how complex your model is over anything video related.

KrisBerg
Posts: 0
Joined: Sun May 25, 2008 10:04 pm

Post by KrisBerg » Sat May 31, 2008 11:43 pm

Hm.. This is weird. I could've sweared my method worked for a while, but i'm experiencing the same bug again now. Very weird. Sorry about the confusion guys.

pinhead_66
Posts: 17
Joined: Wed Oct 16, 2002 10:09 am
Location: Belgium

Post by pinhead_66 » Sun Jun 01, 2008 8:19 pm

just a question,
how big is the file your working on? are you using subsurf?
is the autosave on? if so how many auto-saves/xx min?

P.S. I have the latest drivers auto installed by ubuntu (8.04) Can't remeber wether I had it under ubuntustudio, but this weekend I experienced the same short lag a couple of times. I can't say my model is expecially detailed.

greets
pin

Clean3d
Posts: 0
Joined: Fri May 09, 2008 11:16 pm

Post by Clean3d » Tue Jun 03, 2008 2:48 am

pinhead_66: The model I'm working on now is 640 faces without the subsurf and mirror modifiers. I've got autosave turned on, but I doubt this is the problem since it's occasionally lagged every couple seconds.

A possible solution:
http://dv-studios.org/eradicor/index.ph ... b=1#c12770

(these are the newest drivers he speaks of, correct?)

Clean3d
Posts: 0
Joined: Fri May 09, 2008 11:16 pm

Post by Clean3d » Fri Oct 17, 2008 6:50 am

Sorry for resurrecting an old thread, but I thought I should post and say that I did find a solution to this problem.

Download the drivers (these ones work for me)

Restart into recovery mode and drop to the root prompt.

Install the drivers.

Restart and everything should work! :)

Post Reply