Blender running slowly on 64-bit windows version of vista

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
Keud Bybor
Posts: 0
Joined: Sun May 06, 2007 2:12 am

Blender running slowly on 64-bit windows version of vista

Post by Keud Bybor » Thu May 29, 2008 12:31 am

When i got my new laptop, the first thing i wanted to do was to try out blender and see how fast it would be. You can understand my dissapointment when i ran blender and the fps was really low. On my old windows xp i had a graphics card with the same ram (512 mb), and it ran as smooth as can be. I know it is not my graphics card on my new computer, because i have benn able to run other games and it ran a ton faster than my old one. Is is a problem with blender? I have tried to get all the latest drivers for my graphics card, but still no luck. Could someone help me out?

ThEpRoPhEcY373
Posts: 0
Joined: Fri Apr 11, 2008 4:57 pm

Post by ThEpRoPhEcY373 » Thu May 29, 2008 4:36 pm

What type of CPU do you have? Most of the rendering is done on the CPU. I'm guessing since you game, you have a pretty descent CPU! What version of Vista are you running? How much memory is installed on your system. What graphics card do you have? Answer these questions for me and then i'll be able to diagnose the problem a little bit better :D !

Keud Bybor
Posts: 0
Joined: Sun May 06, 2007 2:12 am

Post by Keud Bybor » Thu May 29, 2008 5:19 pm

I have 4gb of ram, i am running on 64-bit vista service pack 1, my graphics card is an nvidia GEforce 8600M GS 512 MB. And it's just not the rendering, but all of blender itself. When i rotate or use the game engine, it only runs at about 10-15 fps, and it should be running at high fps. Thank you for your time in helping me out here!

ThEpRoPhEcY373
Posts: 0
Joined: Fri Apr 11, 2008 4:57 pm

Post by ThEpRoPhEcY373 » Thu May 29, 2008 10:14 pm

When you say "rotating", do you mean just rotating an object in the scene? Holding the middle mouse button and dragging for example? Do you have the latest drivers for your card?

Keud Bybor
Posts: 0
Joined: Sun May 06, 2007 2:12 am

Post by Keud Bybor » Fri May 30, 2008 12:47 am

Yeah...anything that has to do with any tyoe of movement like playing the animation or physics or anything it just runs slowly...i have gotten all the latest drivers and everything. I was hoping you could tell me what the problem was. Thank you.

ThEpRoPhEcY373
Posts: 0
Joined: Fri Apr 11, 2008 4:57 pm

Post by ThEpRoPhEcY373 » Fri May 30, 2008 1:11 am

Man...i'm kind of stumped :cry: ! You said you just got your new laptop? If not, how's your fragmentation looking for you hard drive? I don't know blender's architecture so i'm not sure if it saves the state in temporary files and moves them back to memory when your ready to use them. I'll try and research some more.

Keud Bybor
Posts: 0
Joined: Sun May 06, 2007 2:12 am

Post by Keud Bybor » Fri May 30, 2008 2:31 am

Well, thank you for your time anyways...maybe blender just isn't cut out for 64-bit windows?

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Fri May 30, 2008 5:26 am

The point of 64 bit operating systems is not that they are faster than 32 bit (they are not) but that they can address a huge memory space. Assuming sufficient memory to avoid swapping both 64 and 32 bit systems will render at similar speeds.

Modeling depends on your graphics card. Blender uses OpenGL for all its drawing. Windows games tend to use Microsoft's Direct X, so game performance does not reflect Blender performance.

Laptops tend to have low-end or on-board graphics chips. They also tend to have poor OpenGL performance. NVidia usually does OpenGL better than ATI and other vendors. Using the vendor's drivers will usually work better for Blendder than Microsoft's since MS is famous for its poor OpenGL support.
maybe blender just isn't cut out for 64-bit windows?
It is really the other way around. Not all platforms are created equal when it comes to running Blender.

Keud Bybor
Posts: 0
Joined: Sun May 06, 2007 2:12 am

Post by Keud Bybor » Fri May 30, 2008 6:31 am

You are probably right....though it is still a bummer. Do you think that there will be a version of blender that might use direct X and could possibly work better for my computer? Do you know of any other programs or something that also use openGL that i could try out and see if that is the problem? Thanks for all you guys' help :D

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Fri May 30, 2008 10:22 am

Keud Bybor wrote:Y Do you think that there will be a version of blender that might use direct X
Probably never.

/Nathan

pinhead_66
Posts: 17
Joined: Wed Oct 16, 2002 10:09 am
Location: Belgium

Post by pinhead_66 » Fri May 30, 2008 1:58 pm

Keud Bybor,

Do you have the Aero special effects on under windows vista? If so, turning off the eye candy might help. On linux Compiz doesn't work well with blender either.

good luck
pin

ThEpRoPhEcY373
Posts: 0
Joined: Fri Apr 11, 2008 4:57 pm

Post by ThEpRoPhEcY373 » Fri May 30, 2008 3:21 pm

I forgot to mention that i'm running Vista Ultimate 64 bit on a Intel E8400 @ 3.0Ghz with an Nvidia Geforce 8800 GT and blender runs blazing fast. So I don't think it has to do with Vista 64 bit, It might be an issue with the GPU. I'm also running Aero, so I don't think that has anything to do with it either. It's worth turning it off though to see if that works!

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Fri May 30, 2008 5:20 pm

I'm also running Aero, so I don't think that has anything to do with it either. It's worth turning it off though to see if that works!
Glad it works for you. We have lots of reports to the contrary. Obviously, this is highly dependant on the video card and driver.

If anyone is having display problems, this is the first thing to turn off.

Keud Bybor
Posts: 0
Joined: Sun May 06, 2007 2:12 am

Post by Keud Bybor » Fri May 30, 2008 7:07 pm

YEAH!! I turned off aero effects and went to "windows classic" and it worked!! problem solved!!!!!!! so whenever i want to play in blender, i should turn off the effects!! Thanks you soo much for your help!! :D :D :D :D :D :D

UPDATE: I actually didn't have aero on, but i had the vista defaut theme, but i turned on aero to see how blender worked, and it worked perfectly!! There must have been something with the vista default that blender didn't like or vice versa, but i could care less why it works, because it works and that is all that matters for me...thanks again for all you guys' help!!

ThEpRoPhEcY373
Posts: 0
Joined: Fri Apr 11, 2008 4:57 pm

Post by ThEpRoPhEcY373 » Fri May 30, 2008 7:41 pm

No problem! Glad you got it to work.

Post Reply