Unable to open/import files

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
Genb
Posts: 0
Joined: Sat Jul 19, 2008 2:16 am

Unable to open/import files

Post by Genb » Sat Jul 19, 2008 2:40 am

Hello,

I have a very strange problem: I am not able to open/import any files with Blender internal. By the way, I am using Windows!


I can open a .blend file by a double-click on the file out of the Windows Explorer, but if I want to open a file internal with Blender (File -> Open... -> marking the file I want to open by right click -> click the button "open").
Either Blender opens nothing and simply brings me back to the main view window or Blender tells me, that it is unable to open it.

The same, if I want to import something (File -> Import -> Choosing "Wavefront (.obj)" for example -> mark the .obj file I want to import by right click again -> Click on "Import a Wavefront OBJ")

Then I get a message about illegal characters in the filename.
After that I tried to simply open a obj-file with the open dialog, but then I get the error message, that Blender can't open file <path> untitled.blend.
But the strange thing is, that I am sometimes able to import the same file. It seems to be a problem, that appears randomly.

What can I do?

Thanks for support and every help you can give me!

Btw: If no one has a solution, should I report it as a bug to the bug tracker?

Regards
GenB

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Sat Jul 19, 2008 10:26 am

Can you post the entire path you're trying to load files from?

/Nathan

Genb
Posts: 0
Joined: Sat Jul 19, 2008 2:16 am

Post by Genb » Sat Jul 19, 2008 3:15 pm

Thanks for your response!
jesterKing wrote:Can you post the entire path you're trying to load files from?
Yes of course! At the moment it is:

C:\test.obj

LetterRip
Posts: 0
Joined: Thu Mar 25, 2004 7:03 am

Post by LetterRip » Mon Jul 21, 2008 5:46 am

File>Open

is for opening blend files only, for obj, 3ds etc you need to use

File>Import>

LetterRip

Genb
Posts: 0
Joined: Sat Jul 19, 2008 2:16 am

Post by Genb » Mon Jul 21, 2008 2:18 pm

But if I want to import obj-files I get the message, that I would have illegal characters in the file name, but this isn't true.

And if I want to open blend files I get the error message "Can't open file: <path> untitled.blend"

Sometimes it works, but very often it doesn't and I get these error messages.

But if I open blend files with a double click (out of the Windows Explorer) I don't have any problems.

But this issue is very annoying.

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Mon Jul 21, 2008 4:20 pm

Can you give more info on what Windows version you are using?

/Nathan

Genb
Posts: 0
Joined: Sat Jul 19, 2008 2:16 am

Post by Genb » Mon Jul 21, 2008 7:26 pm

Windows Vista

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Mon Jul 21, 2008 8:44 pm

And what specific language? Any specific region settings?

/Nathan

Genb
Posts: 0
Joined: Sat Jul 19, 2008 2:16 am

Post by Genb » Tue Jul 22, 2008 8:37 am

German

Genb
Posts: 0
Joined: Sat Jul 19, 2008 2:16 am

Post by Genb » Fri Jul 25, 2008 5:37 pm

No idea?

3DModelerMan
Posts: 0
Joined: Fri Jul 25, 2008 5:26 pm

hmmmm

Post by 3DModelerMan » Fri Jul 25, 2008 8:00 pm

Try reinstalling blender and see if that helps, also remember that open is for opening .blend files and that import is for importing other file types, you have to make sure that the importer you use is correct for your file type also, so... import .obj will not work on a .3ds
and import .3ds will not work on a .obj etc. :D
If life was like animation, we would all be puppets.

Genb
Posts: 0
Joined: Sat Jul 19, 2008 2:16 am

Post by Genb » Sat Jul 26, 2008 2:48 pm

I have reinstalled Blender now, but the problem is still there.

If I want to open for example test.blend, I still get the error message: "Can't open C:\untitled.blend"

But that's strange. i want to open test.blend and not untitled.blend.

Genb
Posts: 0
Joined: Sat Jul 19, 2008 2:16 am

Post by Genb » Sat Jul 26, 2008 6:43 pm

Problem is solved and it was that simple... :roll:

I didn't know that I have to ensure, that the text field (to the left site of the Cancel button) has to have the name of the object I want to open.

I just thought it would be enough simply to mark the file I want to open by right click, but I also have to click it once again with the left mouse button.
Damn! It can't be, that I wasn't able to figure that out in this long time.

Oh my gosh, this was annoying as hell, but finally, it is solved.

Thanks again for your help!

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Sat Jul 26, 2008 9:04 pm

I'm glad it got sorted out :)

/Nathan

Post Reply