Blender world settings

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
zhenelzuar
Posts: 0
Joined: Sun Jun 19, 2011 1:23 pm

Blender world settings

Post by zhenelzuar » Tue Jun 21, 2011 7:15 pm

Hi all!

I'm learning now from the cgmasters' environment tutorial.
Everything seems to be OK, but I discovered that there is a little problem (see the attached image). As you see, the ambient colors look different on each screenshot.
The video snapshot has the right colors. When I open the author's file, I don't see the orange light from the lamps. And I did my work according to the tutorial.

World settings and lights are same in each file.

Can you help me?

Here is my work http://verbaska.com/warehouse.rar

Image

Wet Sponge
Posts: 0
Joined: Tue Jun 21, 2011 12:04 am
Location: England, UK

Post by Wet Sponge » Wed Jun 22, 2011 8:11 am

Hi there,

Firstly, I don't know how you were able to render the images, as there was no camera in the scene (I downloaded your .blend file).

Secondly, after adding a camera and rendering, I got a similar result to that of the video snap shot you posted - deep colours with an orangy cast. I didn't get a render like yours.

I didn't change any settings, so I'm not sure why your renders are so different.

What version of Blender are you using, and what revision number? I'm using Blender 2.57b, revision no: 36339. Are you using an external renderer? I used Blender's internal render engine.
I doubt it has anything to do with the version, but there has to be an explaination!

Sorry I can't offer an answer at this time!


EDIT:
I now see you do indeed have a camera in the .blend file, but the organisation of the blend file seems somewhat erratic: none of the objects have original names describing what they are. Also, why use every single layer?
I also see that there are two 'World' layers in the Outliner. Perhaps their settings are in conflict?

zhenelzuar
Posts: 0
Joined: Sun Jun 19, 2011 1:23 pm

Post by zhenelzuar » Wed Jun 22, 2011 7:56 pm

Well, I use the same version of Blender.
I used the same render engine (and the same editor) and I got these strange results .

There are no conflicts with the settings, and I didn't give names to the objects because I thought that I'm the only who use this file.

Wet Sponge
Posts: 0
Joined: Tue Jun 21, 2011 12:04 am
Location: England, UK

Post by Wet Sponge » Thu Jun 23, 2011 5:50 am

zhenelzuar wrote:Well, I use the same version of Blender.
I used the same render engine (and the same editor) and I got these strange results .

There are no conflicts with the settings, and I didn't give names to the objects because I thought that I'm the only who use this file.
I'm still working on this for you. xD

I've seen that under the World tab the Mist settings are checked but the Intensity was at '0.000', I increased it to around '0.700' and got more the result from the author's render screen shot.

I also see, in those screen shots, that yours has more red/purple in the floor, but the author's doesn't. Plus, his lamps are actually emitting light. It also looks like the author has used some compositing. Have you finished the whole tutorial?

I'll keep fiddling with it. :P

zhenelzuar
Posts: 0
Joined: Sun Jun 19, 2011 1:23 pm

Post by zhenelzuar » Fri Jun 24, 2011 10:52 am

I opened my blends on three different computers and I didn't see orange lights.

I checked it in 2.49 version and ... it works! I see a true orange color. The bad news are that I can't see the textures, and I'd like to use recent versions.

Maybe there is a problem with Python? Or corrupt installations?
I'd just downloaded the distributive from this website and the latest version of Python, and then installed them.

I have the same textures like the author's, no purple color added.

I've finished about 80%. I need to model plants, make more normal maps and add ambient occlusion.

zhenelzuar
Posts: 0
Joined: Sun Jun 19, 2011 1:23 pm

Post by zhenelzuar » Fri Jun 24, 2011 8:44 pm

GOT IT :D
It took me a week to understand.

Go to "Blender Game", render settings and uncheck 'Color management'

Thank you anyway

Post Reply