Zoom broken since upgrading to OS X Lion

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

WibXL
Posts: 0
Joined: Sun Jul 24, 2011 1:20 pm

Zoom broken since upgrading to OS X Lion

Post by WibXL »

Has anybody else found that since upgrading to OS X Lion they can no longer zoom properly with their magic mouse. Moving a finger up or down on the magic mouse used to zoom in or out but now it mainly scrolls the screen around instead, apart from the odd occasion when it does work.

I guess this could be down to the new gestures introduced with OS X Lion but I can't seem to find any settings that will return it to its old behaviour.

Any help would be appreciated.

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv »

I guess this could be down to the new gestures introduced with OS X Lion
When keys are not working in Blender, it is often because your window manager or operating system is grabbing them before Blender can see them.

Also check Blender's key mapping in User Preferences. Settings are customizable in new Blender.

WibXL
Posts: 0
Joined: Sun Jul 24, 2011 1:20 pm

Post by WibXL »

stiv wrote:
I guess this could be down to the new gestures introduced with OS X Lion
When keys are not working in Blender, it is often because your window manager or operating system is grabbing them before Blender can see them.

Also check Blender's key mapping in User Preferences. Settings are customizable in new Blender.
Thank you for the help but unfortunately nothing I can do seems to be able to get zooming back to how it was before Lion. I think that I'm just going to have to bite the bullet and not bother with mouse zooming for now.

WibXL
Posts: 0
Joined: Sun Jul 24, 2011 1:20 pm

Post by WibXL »

After spending some time going through Lion's and Blender's settings I still can't get my magic mouse to work as it should but I have found and alternative zoom method which works almost as well.

Turn on 3 button mouse emulation in your Blender settings and if you then hold down ctrl, option (alt) and the left mouse button moving the mouse backwards and forwards will zoom you in and out.

mrhiyuck
Posts: 0
Joined: Wed Jan 04, 2012 1:33 am

Post by mrhiyuck »

I encountered the same problem with the single finger scroll on the magic mouse. The reason is that blender and lion are conflicting on the same mouse input - Lion makes the mouse pan like the trackpad confuses blender with both trackpad and mouse inputs.

Assuming you're on 2.6, there is an easy fix: File -> User Preferences -> Input. Go down the drop down menus: 3D -> 3D View (Global). Each possible input method (keyboard, trackpad, mouse) for zoom view, move view, etc is listed. Uncheck the "Move View" with the mapping "Mouse/Trackpad Pan". This will disable the emulated pan on the mouse and solely use the scroll for zooming. (Alternatively, you can remove the zoom features for the pan, just uncheck the two "Zoom View"'s listed with the key "Wheel Down" and "Wheel Up")

This alongside the Better Touch Tool (http://blog.boastr.net/?page_id=1722) to emulate a Middle Click with a Two Finger Click makes using the Magic Mouse actually enjoyable again.
Even in literature and art, no man who bothers about originality will ever be original: whereas if you simply try to tell the truth, ... you will, nine times out of ten, become original without ever having noticed it.
~C. S. Lewis

kniteriter22
Posts: 0
Joined: Thu Mar 29, 2012 10:25 pm
Location: Portland, OR

Inertial Scrolling is the issue

Post by kniteriter22 »

Like mrhiyuck said, you can use the User Preferences to fix the pan/zoom confusion within Lion, but the inertial scrolling you cannot. In previous versions of OSX zooming would follow the speed of your finger while you move it up or down, but now with Lion the zooming doesn't occur until after you have lifted your finger from the mouse, therefore removing the ability to finely scroll, which really helps while modelling. Does anyone know of a way to fix this issue, or is anyone working on a fix?

ldo
Posts: 0
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Post by ldo »

Your Mac can run either Linux or Windows, you don’t have to be stuck with Apple’s idea of an OS.

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv »

I suspect most Mac users would regard changing their operating system as blasphemy. And even I am appalled at the idea of replacing it with Windows.

Tehrasha
Posts: 0
Joined: Wed Apr 21, 2010 6:21 am
Location: Iowa

Post by Tehrasha »

Of course, then you have a Mac with an alternate OS which has little or no support for the Magic Mouse. Making how Blender reacts to it unpredictable at best, and.. Hey! I think I see a pattern!

Get a real mouse with buttons and a wheel.
Spacemice Wiki -- Input devices for a 3D world.
Spacemice / Blender Compatibility

kniteriter22
Posts: 0
Joined: Thu Mar 29, 2012 10:25 pm
Location: Portland, OR

Post by kniteriter22 »

The OS is not the issue or discussion here, it's how Blender interacts with the default mouse or trackpad that is shipped with Apple computers. I dug out my old Mighty Mouse, and it worked as expected because it doesn't use inertial scrolling like the Magic Mouse and Trackpad. It appears that Blender doesn't track your interactions with scrolling to zoom until after you lift your finger off the Magic Mouse or Trackpad which causes massive zooming in and out so you can't even see what you were trying to zoom to. Panning with two fingers on the Trackpad doesn't suffer from this problem, so I wonder if the scrolling to zoom just isn't using the same technique of interacting with the OS as the panning on the Trackpad is. A little baffling.

ldo
Posts: 0
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Post by ldo »

If “the OS is not the issue or discussion here”, then why did the problem only happen after “upgrading” to OS X Lion? The hardware was exactly the same as before, and the behaviour of Blender was exactly the same as before.

kniteriter22
Posts: 0
Joined: Thu Mar 29, 2012 10:25 pm
Location: Portland, OR

Post by kniteriter22 »

What I meant to say, which obviously didn't come across was that I'm not changing the OS that I'm using just for Blender, because all the other software I use for production is licensed only for Mac, and is not available for Linux. So what I meant was I was hoping for a solution that wouldn't disrupt my current work flow.

atartanian
Posts: 0
Joined: Sun Apr 22, 2012 9:37 pm

Re: Inertial Scrolling is the issue

Post by atartanian »

kniteriter22 wrote:Like mrhiyuck said, you can use the User Preferences to fix the pan/zoom confusion within Lion, but the inertial scrolling you cannot. In previous versions of OSX zooming would follow the speed of your finger while you move it up or down, but now with Lion the zooming doesn't occur until after you have lifted your finger from the mouse, therefore removing the ability to finely scroll, which really helps while modelling. Does anyone know of a way to fix this issue, or is anyone working on a fix?
You can disable inertial scrolling for the magic mouse or the trackpad by going to System Preferences > Universal Access > Mouse & Trackpad > and then click on the "Trackpad Options" or "Mouse Options" button. Then change the "scrolling" dropdown menu to "without inertia"

This makes Blender much more useable with the Mac Book Pro trackpads. I'm still trying to figure out how to remap scroll to zoom the way it used to be... I'll definitely update this thread if I figure out a solution.

jeffwillden
Posts: 0
Joined: Fri Mar 22, 2013 6:47 am

Post by jeffwillden »

Since control-middle mouse (magic mouse slide up and down) has been taken by the OS to zoom the whole viewport, it would make sense to allow option (alt)-middle mouse, since that doesn't seem to do anything in the view. From a usability perspective, in the preferences I should be able to choose option and finger slide on the magic mouse or trackpad, and it recognizes only the option key, it doesn't recognize any mouse or trackpad gestures. So I don't see how to tell the Preferences pane that I want the option-trackpad gesture for zoom.

joe312117
Posts: 0
Joined: Sun Apr 07, 2013 11:18 am

Post by joe312117 »

Hi Guys,

I found that it works while we just hold down control and scroll magic mouse. Otherwise it will pan or rotate when we are scrolling.

or we can just swap the ctrl in user setting

in 3d view
uncheck the ctrl on both zoom view (Mouse/Trackpad Pan) and
check the ctrl on both rotate view (Mouse/Trackpad Pan) / (Mouse/Trackpad Rotate)

Post Reply