[SOLVED] Slow viewport performance Blender 2.59

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

MadMesh
Posts: 0
Joined: Wed Mar 17, 2004 1:50 pm
Location: The Netherlands

[SOLVED] Slow viewport performance Blender 2.59

Post by MadMesh » Sat Sep 17, 2011 1:16 am

Blender 2.59 viewport performance is very slow on my machine. My test scene runs very good on Blender 2.49 but in Blender 2.59 it's very slow.

What i've tried (and doesnt make any difference)
- turned on VBO's
- Installed latest Graphic card drivers
- Disabled vertical sync in my Nvidia panel


Windows 7 64 bit
2X Quad core Intel Xeons
MSI Geforce GTX 560 TI Twin Frozr II
Last edited by MadMesh on Tue Sep 20, 2011 11:10 am, edited 2 times in total.

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Sat Sep 17, 2011 1:20 am

Turn off compositing window managers and themes

Play with Blender's Window Draw Mode setting

MadMesh
Posts: 0
Joined: Wed Mar 17, 2004 1:50 pm
Location: The Netherlands

Post by MadMesh » Sat Sep 17, 2011 9:38 am

Turned off "desktop composition" and I have the windows 7 basic theme.

No difference in performance in 2.59, Blender 2.49 still runs the scenes fine.

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Sat Sep 17, 2011 5:21 pm

Play with Blender's Window Draw Mode setting
Most likely, this is an OpenGL drawing issue.

simtron
Posts: 0
Joined: Sat Sep 11, 2010 8:33 pm

Post by simtron » Sat Sep 17, 2011 9:01 pm

Same kinda problem on my friend's system.Along with a little lag, the vertex selection pisses of the user.If he select one vertex, a completely unrelated vertex gets selected.

i7 3.2GHz
4GB Ram
Windows 7
NVidia card( worth around 700$)

Will the problem go away If the os is substituted by linux as in Ubuntu?

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Sat Sep 17, 2011 9:32 pm

the vertex selection pisses of the user.If he select one vertex, a completely unrelated vertex gets selected.
Usually caused by Full Screen Anti-Aliasing messing with the z-buffer. Turn FSAA off.

MadMesh
Posts: 0
Joined: Wed Mar 17, 2004 1:50 pm
Location: The Netherlands

Post by MadMesh » Sat Sep 17, 2011 9:50 pm

What i'm testing for is the speed at which I can scrub through the animation. The scene i'm using is sizable but Blender 2.49 has little problems with it 2.5 is stuttering.

I played with the drawing modes, only "full" gave me a significant change,.. for the worse. :(

MadMesh
Posts: 0
Joined: Wed Mar 17, 2004 1:50 pm
Location: The Netherlands

Post by MadMesh » Sat Sep 17, 2011 10:00 pm

Viewport performance is just fine with panning zooming rotating in the same test scene as above. Scrubbing through the animation is horrible. When scrubbing in shaded or wireframe mode there is no difference, its equally bad.

MadMesh
Posts: 0
Joined: Wed Mar 17, 2004 1:50 pm
Location: The Netherlands

Post by MadMesh » Sat Sep 17, 2011 10:13 pm

Solved a piece of the puzzle. :)

When in Fullscreen mode everything runs fine, ALT+A, stepping through the animation with the arrow keys, all smooth.

Unfortunately I have no timeline available in full sceen or any other window I need.

CTRL+up and down will now be my most used shortcuts, unless someone can explain this behaviour?

MadMesh
Posts: 0
Joined: Wed Mar 17, 2004 1:50 pm
Location: The Netherlands

Post by MadMesh » Sun Sep 18, 2011 11:26 am

The responsiveness of changing parameters like material settings is still sluggish, so is selecting objects in the viewport.

simtron
Posts: 0
Joined: Sat Sep 11, 2010 8:33 pm

Post by simtron » Sun Sep 18, 2011 4:57 pm

Where do I find this fssa check box??
I couldn't find it in the user preference editor!!!
help me :roll:

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Sun Sep 18, 2011 5:03 pm

Where do I find this fssa check box??
It is a operating system or graphics card setting. Not in Blendeder's User Prefs.

MadMesh
Posts: 0
Joined: Wed Mar 17, 2004 1:50 pm
Location: The Netherlands

Post by MadMesh » Mon Sep 19, 2011 11:42 am

I tested this problem at work with a different scene on a different PC, same problem.

Windows 7 professional 32bit
Intel i7
GeForce GT 240

Blender 2.49 flies when scrubbing through the animation, 2.59 is struggling to keep up.


I's this known bug, is anyone having this problem besides me?

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Mon Sep 19, 2011 6:01 pm

Scrubbing is playing back frames from disk or memory. From disk, you are limited by your I/O speeds. Memory is faster, but uses lots of memory. There is a setting for how many frames to pre-fetch in order to speed things up.

MadMesh
Posts: 0
Joined: Wed Mar 17, 2004 1:50 pm
Location: The Netherlands

Post by MadMesh » Mon Sep 19, 2011 7:20 pm

stiv wrote:Scrubbing is playing back frames from disk or memory. From disk, you are limited by your I/O speeds. Memory is faster, but uses lots of memory. There is a setting for how many frames to pre-fetch in order to speed things up.
I'll give it a try.

I'm curious though, how does this work in 2.49b? And why is 2.59 perfectly capable of playing through the frames when in fullscreen mode?

Post Reply