The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
Posts: 1
Joined: Thu Oct 24, 2002 1:23 am


Post by jonnifonda »

Is it possible to import/export object in/out of Blender

Posts: 5
Joined: Fri Oct 18, 2002 11:35 pm

Post by atariman5000 »

You can export an object using DXF or VRML. You can import = Append an object into blender from another blender file. You can also import a DXF or VRML file into blender using the OPEN option. Using the OPEN option will no erase the work you have done; it will add the DXF or VRML object to your work. I hope this answers your question.

- Atariman5000 -

Posts: 0
Joined: Sat Mar 01, 2003 5:01 am

Post by Ian_Christie »

Interesting, as you say Blender is supposed to import a VRML file using the open command.

I goto

File --> Open

Navigate to where the file is (originally exported from Wings 3D to VRML 2.0 as a WRL file), the WRL file does not have a little yellow box next to it (like the blend files) and even if it were .VRML still doesn't have the box. When I try and open either the VRML or WRL file, blender crashes.

I'm on an Athlon T-Bird 1.33, 256MB ram running Windows XP and Blender 2.26

Posts: 0
Joined: Sat Mar 01, 2003 5:01 am

Post by Ian_Christie »

Just tried some stuff, 2.25 will import the VRML file, although, with some missing polygons. Rendering causes 2.25 to crash. 2.26 crashes when importing the file. If saved as a blend file in 2.25, 2.26 will read that, but eve with applying a material to it, it won't show up (with lights) in a render. :(

Posts: 47
Joined: Wed Oct 16, 2002 3:05 am
Location: NM, US

Post by ray_theray »

Have you tried recalculating the normals on the imported mesh with CTRL-N? This could be the problem. Maybe. (Sorry, I don't have any vrml's to test this out).

Posts: 239
Joined: Mon Oct 14, 2002 8:15 am
Location: Sweden

Post by Jamesk »

It seems VRML import is broken on 2.26. Use 2.25 - import, save a blender file, append the object into 2.26.

Posts: 0
Joined: Sat Jun 10, 2006 3:36 pm

Post by banjin »

I have the same problem with version 2.41. (I can't seem to find older versions anywhere.) If I export a VRML out of Blender, I can't even import it back in ! Says it's not a Blender file :shock:

Post Reply