Orbit & Pan not working (Mac)

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
roksraka999
Posts: 0
Joined: Mon Jun 24, 2013 12:32 pm

Orbit & Pan not working (Mac)

Post by roksraka999 » Mon Jun 24, 2013 12:41 pm

I just downloaded blender a few hours ago, and i'm already highly frustrated with the navigation. I'm on a mac, but i'm using a normal 3-button mouse (razer orochi) which i bought especially for my CAD and modelling work since apple's magic mouse was a bit impractical...
As I said in the title, i cannot orbit or pan. I have messed around with the settings, and the software seems to recognise my mouse's middle button when i tried to remap the controls...the middle button also works perfectly in other programs.
i know i could try emulating a 3-button mouse, but than there would be no point buying a 70$ mouse :) any suggestions?

Mac OS 10.8.3
Macbook Pro 13" 2009
Intel Core 2 Duo 2.4 Ghz
4GB RAM
Nvidia GeForce 9400M

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Mon Jun 24, 2013 5:12 pm

I have messed around with the settings
By 'settings', do you mean Blender's interface settings in User Preferences, or some operating system/mouse driver settings?

roksraka999
Posts: 0
Joined: Mon Jun 24, 2013 12:32 pm

Post by roksraka999 » Tue Jun 25, 2013 12:42 am

stiv wrote:
I have messed around with the settings
By 'settings', do you mean Blender's interface settings in User Preferences, or some operating system/mouse driver settings?
blender's settings :) my mouse works perfectly with all the other programs so i don't think the problem lies in the system

bybinhabr
Posts: 0
Joined: Sat Oct 19, 2013 9:37 pm
Location: Brazil

how to solve this...

Post by bybinhabr » Sat Oct 19, 2013 9:41 pm

roksraka999 wrote:
stiv wrote:
I have messed around with the settings
By 'settings', do you mean Blender's interface settings in User Preferences, or some operating system/mouse driver settings?
blender's settings :) my mouse works perfectly with all the other programs so i don't think the problem lies in the system
it IS a system problem!
Go to Preferences>Mission Control shortcuts>remove all MOUSES shortcuts... now your Blender works!

Post Reply