Export to DirectX Mesh *.x Not displaying in Qinsy 3DDisplay

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Thu Aug 22, 2013 12:02 am
Location: Melbourne, Australia

Export to DirectX Mesh *.x Not displaying in Qinsy 3DDisplay

Post by aternes » Thu Aug 22, 2013 1:23 am

Hello, I'm new to blender, I'm a hydrographic surveyor and i'm using blender to create an accurate 3D representation of our survey boat using DXFs and CAD drawings. The purpose being able to use the 3D boat with GPS and create a real time visualisation as we collect 3D data of the seafloor.

I created a rough model of the boat by mirroring the Hull and cabin and appying the mirror. Other than finishing my edits and closing edit mode and returning to object mode is there any other options i should be aware of before exporting? do i need to finialise the object somehow?

I just did an export to *.x from object mode and it seemed to work.
I opened the *.x file in the directX viewer and the model was there.
However when i opened the file the Qinsy 3D display, it didn't display the model at all yet the light source was still able to cast a shadow of the model.

I contacted support from Qinsy and he had the same problem. He managed to get the model to work in the Qinsy 3D Display, but he first had to convert the original *.x model in milkshape to a format that AC3D could read and then exported the AC3D model to *.x model. This version worked.

I'm not sure why an AC3D *.x export worked and why the Blender *.x didn't??? I really would like to avoid using AC3D just to convert to a *.x that i can use.

The qinsy support guy suggested i missed some options on exporting *.x?
Other than export save to *.x I didn't see any other options. Is there something i need to do to my model first before exporting?

Andrew Ternes

Post Reply