Importing DXF files

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
aughey
Posts: 4
Joined: Tue Oct 22, 2002 2:39 pm

Importing DXF files

Post by aughey »

I'm trying to take models created in a cad program (Unigraphics) and then import them into Blender for further editing. The common file format is DXF which Unigraphics can export. However, when I try to import a dxf file into Blender, there are a lot of holes in the model where faces should be.

There is a very simple dxf file at http://www.washucsc.org/~jha/test.dxf that demonstrates this problem. This model is a simple block with a hole in it. The faces that attach from the sides to the hole are missing. The interesting part is that not all the faces are missing, just some of them.

Any ideas why this might be happening?

John Aughey

BgDM
Posts: 30
Joined: Wed Oct 16, 2002 3:55 pm

Post by BgDM »

When you import, change to edit mode and select all verts. The remove doubles. DXF format has a tendancy to make a lot of double verts. THis should fix most of your problem.

You will still have to clean up the mesh a fair bit though after you do this.

BgDM
Reality is an illusion caused by lack of alcohol.

aughey
Posts: 4
Joined: Tue Oct 22, 2002 2:39 pm

Post by aughey »

I've tried that and it doesn't work. Try it on the dxf model that I posted.

John

joeri
Posts: 96
Joined: Fri Jan 10, 2003 6:41 pm
Contact:

Post by joeri »

It's propably a bug.
Try changing a 1 into a 0 somewhere in the sourcecode.
It's usaly a sluggy bug like that in blender.

"It works on my cube" is a know programmers "test" case.

I find importing dxf in 2.25 works alot better.
You can find 2.25 here: http://www.blender3d.org/Download/

jo
Posts: 0
Joined: Fri Dec 12, 2003 4:49 pm

Post by jo »

i imported it in cinema4d 6 ce+ and it looks like it should. so it seems to be a blender bug. but i exported this file in cinema4d as dfx again. this new dxf file made by cinema4d looks in blender like it should without the missing faces!!! after this i compared the two dxf files with an editor and they looked completely different. so it seems that there are two different versions of dxf files.

alltaken
Posts: 109
Joined: Mon Oct 14, 2002 7:08 am

Post by alltaken »

DXF is not a single version of file format.

there is the original DXF which was 100% 2d.

then they got autocad with 3d settings etc... so the format developed, i am guessing your issue is somewhere in that part of it.

Alltaken

Al-Capone
Posts: 0
Joined: Sat Jan 24, 2004 9:33 am

Post by Al-Capone »

Working with cad, I do this alot, the best way to do this, is to export it out that will trianglet the object, such as 3ds format, then import it with the cad program and save it as dxf, you will see everything you created.

Post Reply