blender sound on linux?

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
zygom
Posts: 0
Joined: Thu Apr 22, 2004 7:42 am

blender sound on linux?

Post by zygom »

hello :)
i don't understand why it's not possible to listen sound in blender(timeline , sequencer ...) on windows xp it's possible to listen sound in realtime with
"alt a" on the timeline but not possible on ubuntu linux
does anyone have this problem?
how to resolve this ?

thanks

kxs
Posts: 0
Joined: Tue Nov 23, 2004 7:31 pm
Location: Poland

Post by kxs »

When I load a wave file to Sound Block Buttons I can listen the file, but when I add it to Sequence Editor and play with Alt+A blender freezes. Everytime. I think that when I was using it about a year ago it all was OK. Did something changed. Or maybe the problem is my Sound System. Which one should I use for Blender to work correctly?

kxs
Posts: 0
Joined: Tue Nov 23, 2004 7:31 pm
Location: Poland

Post by kxs »

so what`s with the sound on linux? it works OK on every other linux machine?

Mats78
Posts: 100
Joined: Thu Oct 17, 2002 5:06 pm
Location: Vantaa, Finland

Post by Mats78 »

so what`s with the sound on linux? it works OK on every other linux machine?
For me it does. I'm using Slackware 10.1 (with some updated parts) and Alsa for sound output. Works well, even though the 'audio mixing buffer' setting has to be set high (using 2048 atm). I think I read somewhere that it should be set as _low_ as possible, so this puzzles me a bit.

The only real problem is that Blender only understands very few sound files - has to be 16bit wawes I guess, but not even all of them work.

Mats

zygom
Posts: 0
Joined: Thu Apr 22, 2004 7:42 am

Post by zygom »

hello kxs and Mats78no


i think there is a true problem for the blender sound on linux

when i check "2048" on the "audio mixing buffer" and then make "alt a" on a wav file in the sequencer , "2048" uncheck itself when i press "esc" to stop playing sound in the sequencer and i can't listen the sound (this is the same case for "256" "512" "1024")

on windows no problem i can listen sound and no problem of unchecking aon the audio mixing buffer

please anyone can help me to resolve this sound problem

bye

zygom
Posts: 0
Joined: Thu Apr 22, 2004 7:42 am

Post by zygom »

:cry: :cry
how can i resolv this problem of sound in blender

what's library use blender for the sound in the sequence editor

openal? other

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing »

SDL is used for sound, afaik

/Nathan

Sanne
Posts: 0
Joined: Tue Jan 28, 2003 9:24 pm

Post by Sanne »

I found I have the same problem (Blender 1.37a, Debian Gnu/Linux Sid [not up to date, though]), and today's testing and tinkering gave me astonishing results:

1. Start Blender, switch to video sequence editor, load a wav with Add/Audio from the sequence editor menu, play the sequence with alt-a

Result: no sound plays from the sequence editor, but playing the sound through the play button on the scene/sound block buttons works, and playing it as a game engine sound works also.

2. Start Blender, hit alt-a in the 3D window before doing anything else and stop again with ESC, switch to video sequence editor, load a wav with Add/Audio from the sequence editor menu, play the sequence with alt-a

Result: sound from the sequence editor works, but not anymore by playing through the scene/sound block buttons nor in the game engine.

zygom, kxs, could you try if you get the same results, especially with point 2? If it's not only me, I think a bug report would be the next step.

Sanne

Post Reply