opening 2.37 blend files in older versions

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
kxs
Posts: 0
Joined: Tue Nov 23, 2004 7:31 pm
Location: Poland

opening 2.37 blend files in older versions

Post by kxs »

when I open blend file saved in 2.37 in a older Blender version the file opens but after a short moment it crashes. I think that`a because of UI as in 2.37 I use Timeline which doesn`t exist in 2.36. And the problem may be resolved with unmarking the Load UI button in the Open File window, but... There could appear a short information when opening files saved in newer version, that it may crash if loading with Load UI option

blendix
Posts: 51
Joined: Wed Oct 16, 2002 1:00 pm

Post by blendix »

This problem is mentioned under 'Important Notes' in the release logs.

I don't think there should be a crash warning. It just shouldn't crash. The problem is that we can't fix 2.36 anymore.

kxs
Posts: 0
Joined: Tue Nov 23, 2004 7:31 pm
Location: Poland

Post by kxs »

OK, you`re right. There`s no point correcting older versions. But maybe you could add such information since the next release. Blender would check under which Blender version the blend file was saved and if the version is newer then the program, the info appears.
It`s just a suggestion. If you think it`s pointless, then don`t do it

joeri
Posts: 96
Joined: Fri Jan 10, 2003 6:41 pm
Contact:

Post by joeri »

I think this is already done as I read in the release notes.
http://www.blender3d.org/cms/Blender_2_37.496.0.html wrote: Important notes
New TimeLine window isn't upward compatible... that means that older Blender releases crash on reading files with a TimeLine window active. This crash has been fixed in 2.37 to not happen again when we add new window types, but that won't help older versions. :)
Maybe next time read the release notes?
It also tells you what is new in the new version.

kxs
Posts: 0
Joined: Tue Nov 23, 2004 7:31 pm
Location: Poland

Post by kxs »

:oops: oh. ok, my mistake :D

Post Reply