Page 1 of 1

Anyone else ever have this problem?

Posted: Sun Jun 26, 2005 8:18 pm
by MarcusIsMe
Okay, I've searched through several forums and Knowledge Bases about this, and I can't find anything that gives me a solution ...

Using 2.37 in Windows XP.

When trying to select vertices or edges, I make the selection and a completely different vertice is selected. For instance ... say I'm trying to select the tip of a sword ... I'll click my right mouse button, and a vertice on the HILT is selected and not the tip.

If I try to select using the box (B), SEVERAL vertices on various parts of the sword (but not the tip) are selected.

Is anyone else having (or has had) this problem?

Posted: Sun Jun 26, 2005 10:34 pm
by z3r0_d
I have a guess, but not knowing exactly how selection works I can't be sure

first, what graphics card do you have? if it is intel, via, sis, or ... well not ati or nvidia are you in 16 bit color? does 16 bit color fix it?

second [if that doesn't work] do you have this problem in vertex select mode?
while in wireframe draw mode?
or in solid mode solid selection disabled?

I would imagine blender is writing colors to the back buffer, then reading that back to do your selection. If blender ignores or your graphics card lies about its actual amount of precision the colors blender reads back may be different from the ones it wrote, causing selection of other verts [or errors...]

Posted: Mon Jun 27, 2005 4:41 am
by MarcusIsMe
Actually, you asked the right questions.

Solved this myself, but here's the details.

Using a Sapphire Radeon x300se 128MB (ATI card).

Had my colors set to 32bit ... this is what Blender didn't like ... switched to 16 bit. Everything OK.

Any idea if and when Blender will support 32bit color?

Posted: Mon Jun 27, 2005 5:02 am
by z3r0_d
blender should work fine with 24 bit color
[32 bit color is 24 bit color with 8 bit alpha channel]
and that card should be good enough to support it

weird that it doesn't work though

Posted: Tue Jun 28, 2005 12:04 am
by MarcusIsMe
It's probably lost in the settings somewhere ... no worries. I'm a beginner, so I'm not through exploring the program.

Posted: Tue Jun 28, 2005 2:59 am
by Rahu
I think it breaks like that if you have AA on. Could be the problem.

Posted: Fri Jul 15, 2005 7:33 am
by wumamor
I can confirm the SAME problem with an nvidia geforce fx 5200. I havent tried it in 16 bit mode yet (but will after i post this) This is really odd that blender all of a sudden doesn't like 32bit mode, because 2.36 worked just fine with it on my system; no hardware or software changes at all here. Hopefully this will be fixed soon in a 2.37b version (one can hope). I'm pretty sure it has something to do with the way the windows are drawn, because i ALSO get the bug where parts of the windo get blurrier when i drag over another part of the window (can get intensely blurry if you do it several times in a row. It looks like blender draws the same thing again over the old but just a millimeter off; its hard to describe without seeing it. I have the latest drivers from nvidia, and have run a driver cleaner and installed older ones but this doesn't help the blurryness. It cannot be AA because with such a mediocre card, I do not run AA or anistropic filtering at all. As i said, hope its fixed soon, because its a pain in the arse to have to switch modes just to run blender (I run photoshop CS2 also and need 32bit for that).

Posted: Fri Jul 15, 2005 7:44 am
by wumamor
Ok, I thought i would post after changing the resolution to 16 bit from 32 bit and I STILL have the blurryness issue and its worse than before. I will have to go back to 2.36 till you guys can get this straightened out. It has to be in blender itself; as I said, I tried SEVERAL older drivers and nothing helped. Hope this is fixed soon, as I absolutely LOVE the translation tools now for dragging and such so you can translate in one axis only with just the mouse and no keyboard shortcuts. Much faster. They will speed up my modeling speed tenfold, as will the better edge selection. On a side note, when i was doing my vertice selections, I would some times also get an edge selected in vertice mode; NOT a vertice just the edge between the two. Kind of odd, that.