Problem with Direct X Export

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
ProjectBlack
Posts: 0
Joined: Thu Aug 25, 2005 8:10 am
Contact:

Problem with Direct X Export

Post by ProjectBlack » Thu Aug 25, 2005 8:13 am

Hard at work making a game... made a model of a mushroom that when exported to .x format, causes a runtime error that when referenced, says that all sides must be triangulated.

Making a simple default sphere and exporting it, we don't get that error.

Highlighted all vertices/faces of the mushroom and coverted to triangles, the triangles are visible in wireframe mode, export, and still the same runtime error.

What's going on with this?

ideasman
Posts: 0
Joined: Tue Feb 25, 2003 2:37 pm

Post by ideasman » Thu Aug 25, 2005 5:58 pm

If this is the python script distributed with blender, file a bug report.

Then it wont get lost in the forums. rather stick out until a developer fixes it.

- Cam

ProjectBlack
Posts: 0
Joined: Thu Aug 25, 2005 8:10 am
Contact:

Post by ProjectBlack » Thu Aug 25, 2005 6:48 pm

ideasman wrote:If this is the python script distributed with blender, file a bug report.
Are you suggesting that there's another method for export in Direct X?

LetterRip
Posts: 0
Joined: Thu Mar 25, 2004 7:03 am

Post by LetterRip » Thu Aug 25, 2005 7:16 pm

It is always possible that you found an unofficial script somewhere or are using an outdated version, hence the caveat.

LetterRip

ProjectBlack
Posts: 0
Joined: Thu Aug 25, 2005 8:10 am
Contact:

Post by ProjectBlack » Thu Aug 25, 2005 8:08 pm

I'm using whatever version it is that came bundled with the latest Blender installer.

Ben
Posts: 9
Joined: Wed Oct 23, 2002 8:32 pm

Post by Ben » Thu Aug 25, 2005 9:22 pm


ProjectBlack
Posts: 0
Joined: Thu Aug 25, 2005 8:10 am
Contact:

Post by ProjectBlack » Thu Aug 25, 2005 11:10 pm

Using the latest... still the same effect.

Also tried using the .3ds plugin, same problem.

Maybe you can look at the basic model and tell me what needs to be done for it to export properly?

http://www.projectblack.com/killermushroom01.blend

Friday13
Posts: 54
Joined: Wed Oct 16, 2002 10:40 pm

Post by Friday13 » Thu Aug 25, 2005 11:49 pm

I tried your file and the model is exported without problems.
Don't miss the sequel: "I still see dead people"

ProjectBlack
Posts: 0
Joined: Thu Aug 25, 2005 8:10 am
Contact:

Post by ProjectBlack » Fri Aug 26, 2005 2:28 am

Actually we figured out the problem now... one of those stupid things.

I forget all about the console... so I happened to alt+tab to it and found a bunch of warnings that said other readers may not like the "." in different material names.

Changing the names of the materials to things without "." allowed a perfect export.

Aka:

"grey.001" ---> "grey001"

fixed the problem.

I wonder if there's a way to highlight faces and apply a texture to *JUST* those faces? I know what I want the mushroom to look like, but can only make a single texture wrap around the sucker.

joeri
Posts: 96
Joined: Fri Jan 10, 2003 6:41 pm
Contact:

Post by joeri » Fri Aug 26, 2005 9:21 am

I think the console output is just stuppid for an app that tries to be fullscreen all the time.

Post Reply