Page 1 of 1

Shapes Problem... I think (oops)

Posted: Mon Feb 20, 2006 11:30 pm
by Howitzer
At this point in time I am trying to decide if Blender has a crazy bug or if I'm insane. I have tried searching the forums for information, and so far, I have found nothing even remotely related. It seems as though no one wants to talk about it, or perhaps it is all in my head.

Perhaps I'm wrong, perhaps the solution is staring me in the face, but here is my problem-

I have a door. The door is the neat star trek kind that slides open. Instead of making the doors separate from the frame, I chose to make it all one mesh, and then use the fantastic shapes tool to open them.

After creating the 'Open' shape animation I set it back to basis I soon realized that Blender was ignoring 'Open' completely. I'd set the 'Open' shape to closed (0.0) at a certain point and open (1.0) a few seconds later. But when playing this back, it doesn't do anything in both render and working views. I drag the line back and forth in the IPO window and I see the slider of the shape tool moving back and forth... but I do not see the door opening or closing. When rendering, it ignores my shape completely...

UNLESS I turn on the Always show current shape for this Object tack button, then turn it off (I double click it). When turned on, this button seems to do nothing, but when turned off again it seems to make Blender wake up and take the shape animation into account... but only in the renderer!

I decided to attempt to recreate the problem, and this time it did that very same thing, but double clicking the 'tack' button not only fixed the animation in the renderer but it also fixed it in workspace view. Also, even more frustrating, is that when I created a new project I made a very simple morph involving a cube, and it worked properly (I didn't have to click the tack button) - unlike both of the earlier attempts.

I saved the three files separately, please tell me what is different between them, and if it is a user error or a program error.

nonworking.blend contains the sliding door with a nonworking shape.

working-halfway.blend contains the same door with a working shape- but change the shape from 'Basis' to 'Open' and back and watch it stop working. Double click the tack button to fix.

working-perfectly.blend contains a new scene with a very simple cube. Drag your mouse in the ipo area to see it morph back and forth. I have tried recreate the problem like the original nonworking.blend, but I couldn't.

If it is indeed a program error, I will submit a bug report. If not, then I appreciate any tips you may have.


Download my Problem

EDIT- Interesting note... 2.37 does NOT have this problem and can load all 3 files and play the RVK/Shapes back correctly. I'm really starting to think this is a bug... 2.40 has the same problem btw, so if it is a bug it must be a problem with the new shapes tool.

Posted: Tue Feb 21, 2006 12:49 am
by Howitzer
After messing around a bit, I figured this must be a bug and submitted it.

Thankyou for your assistance :roll:

Note - Using the ipo drivers seems to fix the problem.

Posted: Tue Feb 21, 2006 1:02 am
by LetterRip
I didn't see your post previously not sure why, replys are usually faster at the elysiun forum of course here the developers can answer...


Posted: Tue Feb 21, 2006 4:18 am
by Howitzer
I figured it out. Turns out it was an empty ObjAction datablock that hindered the Shape keys. I'm not sure how it got there or what ObjAction is supposed to do... but deleting it in the Action editor seems to solve the problem.



It could still be a bug, as I don't see how the datablock could cause these problems.


Turns out, it was a user error. OOOOPS. I know now to never click this button....

Pass it on, tell your friends!