Middle mouse button "Sticks" - OS X

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
dschnell289
Posts: 0
Joined: Fri Nov 05, 2004 6:21 pm

Middle mouse button "Sticks" - OS X

Post by dschnell289 »

I've posted this question before on elysiun about a year ago, and never had it answered. The problem never went away, I just ignored it. Now I can't.

Here's the scenario: OS X Panther (fully updated) on iMac 1.8 G5 (original flat iMac) with Nvidia GF Ultra FX 5200. Two user accounts.

The first account that I log into and use Blender, all is well (after a reboot). If I log off/switch users and use blender on the other account, when I click the middle mouse button to orbit, it "sticks" (orbits follows the mouse as if I'm still holding the button down) and I can't un-orbit until I alt-LMB. This goes on indefinitely. The order of account login doesn't matter. And it messes up the mouse action in the rest of the OS environment (dock zoom effect, highlighting buttons/combo box text items, etc). This can be resolved by force quitting the finder (through Activity monitor) and letting it restart itself.

I've tried deleting all preference files, .b.blend, using different mouse, , making a new user, even re-installing OS X (I had other issues anyway). I've tried making a local blender folder per user instead of using the applications folder. Nothing helps.

Is this something that others have experienced?
----

Post Reply