Page 1 of 1

Py 2.6 Support Planned??

Posted: Thu Oct 16, 2008 5:01 am
by FuzzCube
:!: Is there planned support for newer versions of python in blender?
Py2.6 and any following updates?

Just a quick question as I am venturing into python programming in my free time (using 2.6) :D
(Would like to be able to use what I learned / scripts I wrote in blender someday)

Posted: Thu Oct 16, 2008 6:37 am
by stiv
I have not built it personally, but I assume Blender will work just fine with Py 2.6, possibly with some minor tweaking. At the moment, you will need to compile Blender yourself.

We will provide Py 2.6 builds when the distributions start supporting it.

Posted: Fri Oct 17, 2008 6:56 am
by jesterKing
I did build once against Python 2.6, and so did ideasman_42. There have not been plans to upgrade for 2.48 - potentially for Blender 2.5, but that is just a maybe. We have different priorities to satisfy first (like getting Blender 2.5 done to begin with).

/Nathan