Page 1 of 1

laborious Obj["Property"]

Posted: Thu Jan 07, 2010 3:30 am
by Doc_Holiday
Hi.
I wanted to ask if there will be an easier Way to access Object Properties in the Future. In the Past, a Dot has sufficed. Now are 8 (eight!) Keystrokes needed to do that ... every Time. (Alt and Shift included.) Not enough, the Keys have as much as possible Distance on the Keyboard. :?

That's not only very laborious, thus the Code becomes hard to read. Too many brackets and quotation marks flooding the code.

Isn't this the Same Thing as the new Properties: getCurrentController().owner ?
Why making so much Difference? (BtW: Cont.getOwner() -> Cont.Owner would be more logical, not?)

Regards, Doc