Python in Red Hat 9 installation error

Scripting in Blender with Python, and working on the API

Moderators: jesterKing, stiv

Post Reply
lascarova
Posts: 0
Joined: Thu Mar 18, 2004 8:03 am

Python in Red Hat 9 installation error

Post by lascarova »

Hi all,

i've installed python 2.3.4 on Red Hat 9.0 (which has 2.2.2), cause i'm using blender 2.3.3.
i had to upgrade my db4 package, which i'm still not sure what it is, but after that it installed fine.now i get the following error.

--warning: Python C API version mismatch for module struct: This Python has API version 1012, module struct has version 1011.
Python 2.3.4 (#1, May 27 2004, 03:26:03)
[GCC 3.3.2 20031022 (Red Hat Linux 3.3.2-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
warning: Python C API version mismatch for module readline: This Python has API version 1012, module readline has version 1011.--

if i try to type anything it shows a few ?'s and jumps to the command prompt.it seems to me that i have to upgrade python api from 1011 to 1012.if this is the case, can someone please tell me where i can download the new version or how i should go about upgrading this version.

thanx,

Post Reply