Animation export contains bad transforms

Animation tools, character animation, non linear animation

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Tue Apr 30, 2013 10:50 am

Animation export contains bad transforms

Post by clevengr »

Hi All,
I apologize if this forum isn't the proper place for the following; I'd welcome it if someone wants to point me to a better location (or just move this) -- but this is the most appropriate place I could find.

I am having a problem with the skeleton files created by the blender2ogre exporter. (Note however that I'm not completely convinced the problem is the exporter rather than Blender itself; hence the posting here.)

Specifically, I am getting the following kind of <bone> elements in the skeleton.xml file:

Code: Select all

    <bone name="BottomBone" id="0" >
      <position y="-0.216652" x="0.000072" z="-1.998395" />
      <rotation angle="0.000000" >
        <axis y="0.000000" x="-0.000000" z="0.000000" />

Notice that the axis of rotation is [0,0,0], which isn't a valid axis. I am guessing this is due to something I'm doing wrong in creating the animation in Blender, but I have spent days trying to figure it out. I have tried resetting the transforms, changing the rotation type to Quaternion, Angle/Axis, Euler, etc; and many other things - to no avail. Does anyone have any ideas?

I'm using Blender 2.66a and blender2ogre 0.5.9 (although I also tried the fork "0.6.0" that some enterprising user posted; no difference).


Post Reply