2.30a OSX update posted

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
ton
Site Admin
Posts: 350
Joined: Wed Oct 16, 2002 12:13 am
Contact:

2.30a OSX update posted

Post by ton »

Two major bugs fixed:
- alt+a animation playback (system hanged in osx only)
- 2-button mouse support (osx users seem to have this more?)

at http://download.blender.org/release/

Actually more (minor) bugs are fixed in it, but that's for release 2.31.

-Ton-

(Oh, yes our sites crawl now... traffic is 10x higher than normal! We do our best to find solutions...)

Money_YaY!
Posts: 442
Joined: Wed Oct 23, 2002 2:47 pm

Post by Money_YaY! »

YaY!
I knew you would not let me down. !
The aramature rigs seem a bit faster to. Huh ? ! ?

Just get that fixed and I will be a happy mad insane fishy ! ^v^ :D

hawksmoor
Posts: 12
Joined: Mon Oct 14, 2002 8:25 am
Location: Italy

Crashing again

Post by hawksmoor »

AAAARGHHH
It's crashing again at start just like 2.30 did:

Date/Time: 2003-11-08 08:46:17 +0100
OS Version: 10.2.6 (Build 6L60)
Host: Computer-di-Andrea-Scatena.local.

Command: blender
PID: 471

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0xb24c3280

Thread 0 Crashed:
#0 0x01b2cc84 in glrSetFunctions
#1 0x019e6a08 in gldDestroyShared
#2 0x01809ad8 in 0x1809ad8
#3 0x00091424 in 0x91424
#4 0x0000a348 in 0xa348
#5 0x0006e568 in 0x6e568
#6 0x000901b8 in 0x901b8
#7 0x00005454 in 0x5454
#8 0x00006030 in 0x6030
#9 0x000066d0 in 0x66d0
#10 0x00003770 in 0x3770
#11 0x00002914 in 0x2914
#12 0x00002794 in 0x2794

Thread 1:
#0 0x90073c08 in mach_msg_trap
#1 0x90005ed0 in mach_msg
#2 0xc0007758 in __ape_internal
#3 0xc0001160 in __ape_agent
#4 0x90020c88 in _pthread_body

PPC Thread State:
srr0: 0x01b2cc84 srr1: 0x0000f030 vrsave: 0x00000000
xer: 0x00000000 lr: 0x01b2c954 ctr: 0x01af74b8 mq: 0x00000000
r0: 0xb24c4000 r1: 0xbffff830 r2: 0xffffffff r3: 0xbffff898
r4: 0xbffff89c r5: 0xbffff8a0 r6: 0xbffff8a4 r7: 0x00000000
r8: 0x000002ac r9: 0xfffff280 r10: 0x00000351 r11: 0x016d2aa4
r12: 0x01af74b8 r13: 0x0000005e r14: 0x01a03570 r15: 0x00000001
r16: 0x00000001 r17: 0x00000000 r18: 0x01af74b8 r19: 0x00000361
r20: 0x00000350 r21: 0xfffff95e r22: 0x0000ffff r23: 0x0000ffff
r24: 0x0000ffff r25: 0x00006060 r26: 0xfffffcaf r27: 0x00000000
r28: 0x01b60120 r29: 0x01b60120 r30: 0xb24c3280 r31: 0x01b2c954

ton please could anybody tell me at least what's wrong? I'm waiting for panther to install, and I think I'll have to erase everything and make a clean install... :-(
thanks a lot in advance

Andrea "hawksmoor" Scatena

knoxer
Posts: 25
Joined: Sun Oct 27, 2002 5:56 pm

Post by knoxer »

What are you system specs? Has any past version of Blender worked for you?

I have no idea what is causing your crash, since no version of Blender has crashed for me, I do have a couple suggestions for you to try.

1) Set your display to 'Thousands' of colors, not 'Millions' (in the Displays System Preferences)

And/Or

1) Delete your current Blender installation(s). All of it (them). 2) Restart your computer. 3) Re-install Blender.

Ender
Posts: 23
Joined: Mon Oct 14, 2002 6:25 am

Post by Ender »

You also might want to try updating to 10.2.8...

hawksmoor
Posts: 12
Joined: Mon Oct 14, 2002 8:25 am
Location: Italy

Post by hawksmoor »

Thanks for the advice, I use 10.2.6, with 320 mb ram on a iMac G3 450 mhz, and I got problems after the 2.26 WWDC special (meaning it takes forever to load) but nothing that prevents me from launching the app.
As to upgrading to 10.2.8 I'm on a 56k connection, can't do a download this big :-(
I'll try to erase all Blender versions installed on my machine and swithing to thousands colours, who knows? could really work.
I'll let you know.

Andrea "hawksmoor" Scatena
===================
From Beyond

Edit: switched to thousands colours and it worked!!! The fastest launch I've ever experienced in Blender!
And the GUI!!! :-)
Thanks a lot, and I mean a real lot ;-)

Post Reply