CVS01 on Slackware 8.0-- Successfull compile

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Post Reply
Posts: 13
Joined: Tue Oct 29, 2002 1:48 am

CVS01 on Slackware 8.0-- Successfull compile

Post by lholt » Mon Dec 02, 2002 8:59 pm

Thanks to Paethon and SirDude I got the CVS to compile on Slackware 8.0
Here's the important parts:

Do the newdir trick mentioned in blender/doc only do it in /blender
You will work from there except for bootstrap which is done in /blender

copy acinclude.m4 from /usr/local/share/libtool/libltdl/
into my blender dir per SirDude fixed the AC_PROG_LIBTOOL failure

Slackware ( and everybody else I think) only gets libXxf86dga.a -- create a dynamic version with

ld -whole-archive -o libXxf86dga.a

in the /usr/X11R6/lib dir
Seemed to work but make (blender/intern) couldn't find it so I did a soft link to it in /lib and that did it.
Probably not the right thing to do, but it worked. Tried
./configure --with-x
but it didn't help. I thought that might include the X dirs.

After what seems like an eternity and bazillions of incompatible pointers, bad argument warning and such, it produces a blender.bin in my newdir/source. It actually runs. Mostly. Still segfaults on any TEXT entry, but by and large the build is ok and I am able to load a .blend and do things with it. Amazing. It even has top,front, and side views!

Thanks for the entertainment. I'll start in on them warnings as soon as I figure out how to submit updates to the CVS. It's all new to me.

Post Reply