Builder blender-2.49b with VS2008. but failed! 0xC0000005

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Sat Jun 05, 2010 9:58 am

Builder blender-2.49b with VS2008. but failed! 0xC0000005

Post by sa_sa_jerry » Sat Jun 05, 2010 10:09 am


CommandLine: D:\Projects\blender-dev\blender-2.49b\bin\debug\blender.exe
Symbol search path is: D:\Projects\blender-dev\build\msvc_9\libs\debug;srv*D:\Symbols*
Executable search path is:
ModLoad: 00400000 024ea000 blender.exe
ModLoad: 7c900000 7c9b2000 ntdll.dll
ModLoad: 7c800000 7c8f6000 C:\WINDOWS\system32\kernel32.dll
ModLoad: 10000000 10056000 D:\Projects\blender-dev\blender-2.49b\bin\debug\SDL.dll
ModLoad: 76b40000 76b6d000 C:\WINDOWS\system32\WINMM.dll
ModLoad: 77dd0000 77e6b000 C:\WINDOWS\system32\ADVAPI32.dll
ModLoad: 77e70000 77f02000 C:\WINDOWS\system32\RPCRT4.dll
ModLoad: 77fe0000 77ff1000 C:\WINDOWS\system32\Secur32.dll
ModLoad: 77f10000 77f59000 C:\WINDOWS\system32\GDI32.dll
ModLoad: 7e410000 7e4a1000 C:\WINDOWS\system32\USER32.dll
ModLoad: 78520000 785c3000 C:\WINDOWS\WinSxS\x86_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.30729.4148_x-ww_d495ac4e\MSVCR90.dll
ModLoad: 77c00000 77c08000 C:\WINDOWS\system32\VERSION.dll
ModLoad: 71ab0000 71ac7000 C:\WINDOWS\system32\WS2_32.dll
ModLoad: 77c10000 77c68000 C:\WINDOWS\system32\msvcrt.dll
ModLoad: 71aa0000 71aa8000 C:\WINDOWS\system32\WS2HELP.dll
ModLoad: 5ed00000 5edcc000 C:\WINDOWS\system32\OPENGL32.dll
ModLoad: 68b20000 68b40000 C:\WINDOWS\system32\GLU32.dll
ModLoad: 73760000 737ab000 C:\WINDOWS\system32\DDRAW.dll
ModLoad: 73bc0000 73bc6000 C:\WINDOWS\system32\DCIMAN32.dll
ModLoad: 73b50000 73b67000 C:\WINDOWS\system32\AVIFIL32.dll
ModLoad: 774e0000 7761d000 C:\WINDOWS\system32\ole32.dll
ModLoad: 77be0000 77bf5000 C:\WINDOWS\system32\MSACM32.dll
ModLoad: 75a70000 75a91000 C:\WINDOWS\system32\MSVFW32.dll
ModLoad: 7c9c0000 7d1d7000 C:\WINDOWS\system32\SHELL32.dll
ModLoad: 77f60000 77fd6000 C:\WINDOWS\system32\SHLWAPI.dll
ModLoad: 5d090000 5d12a000 C:\WINDOWS\system32\COMCTL32.dll
ModLoad: 1e000000 1e306000 D:\Projects\blender-dev\blender-2.49b\bin\debug\python26_d.dll
ModLoad: 10200000 10323000 C:\WINDOWS\WinSxS\x86_Microsoft.VC90.DebugCRT_1fc8b3b9a1e18e3b_9.0.30729.1_x-ww_f863c71f\MSVCR90D.dll
ModLoad: 003b0000 003c5000 D:\Projects\blender-dev\blender-2.49b\bin\debug\pthreadVC2.dll
ModLoad: 71ad0000 71ad9000 C:\WINDOWS\system32\WSOCK32.dll
ModLoad: 6ad40000 6bb1a000 D:\Projects\blender-dev\blender-2.49b\bin\debug\avcodec-52.dll
ModLoad: 003d0000 003ec000 D:\Projects\blender-dev\blender-2.49b\bin\debug\avutil-50.dll
(cbc.4c0): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=00000003 ebx=003f8130 ecx=003fa014 edx=949b0000 esi=003f8130 edi=ffffffff
eip=7c91d503 esp=0013f6a0 ebp=0013f6b4 iopl=0 nv up ei ng nz ac pe cy
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00010297
7c91d503 0111 add dword ptr [ecx],edx ds:0023:003fa014=????????

can't get ideal it' seem not go into the main function,
just popup a dialog say:

The application failed to initialize properly (0xC0000005). Click on OK to terminate the application.

all lib/windows dependent library is get form svn...

Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Sun Jun 06, 2010 4:22 pm

.dlls are failing to load. That suggests something is wrong with your libraries - debug vs no debug, different compiler, linkage...

Please don't create multiple threads for the same issue.

Posts: 7
Joined: Fri Oct 25, 2002 5:14 am

Post by Anthony » Sun Jun 06, 2010 8:45 pm

I had the same problem. Have you tried to build with scons?

Posts: 0
Joined: Wed Jun 02, 2010 9:55 pm

Re: Builder blender-2.49b with VS2008. but failed! 0xC00000

Post by qmaster » Mon Jun 14, 2010 3:55 pm

Hi sa_sa_jerry,

I have exactly the same error using VS2008 on XP.
Have you discovered the error reason ?

Posts: 0
Joined: Sun Oct 10, 2010 3:58 pm

Post by wyd124 » Sun Oct 10, 2010 4:11 pm

I also have meet this issue.

blender.exe generated by Scons/VC can run correctly.

However, the blender.exe compiled/linked by VS2008 Express can not run with error info:

Debugger:: An unhandled non-continuable exception was thrown during process load
The program '[3204] blender.exe: Native' has exited with code -1073741819 (0xc0000005).

How to fix the issue under VS 2008 Express ?


Post Reply