Import Images as Plane - Need help with PNG File

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
themaddis
Posts: 3
Joined: Sun May 27, 2012 12:03 am

Import Images as Plane - Need help with PNG File

Post by themaddis » Sun May 27, 2012 12:23 am

Hi, I am very new to blender. I have spent all day getting my head around it.

I am trying to import a png but every time a do this, however much i try, theres always white in the area that should be transparent.

When i click on 'Solid' in the viewport shading, the image looks right,:

Image

But when i go to render / view in texture mode, i get this:

Image


I have looked at many videos but all say different things. Can someone please help?

Thanks in advance :D

Maddis[/img]

themaddis
Posts: 3
Joined: Sun May 27, 2012 12:03 am

Re: Import Images as Plane - Need help with PNG File

Post by themaddis » Tue May 29, 2012 3:30 pm

Is this the best place to post for support? if not where a should i go?

Thanks in advance

stiv
Posts: 3645
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Tue May 29, 2012 6:30 pm

The best place to go for questions about *using* blender are the forums at blenderartists.org . Discussions here are more focused on Blender development.

themaddis
Posts: 3
Joined: Sun May 27, 2012 12:03 am

Post by themaddis » Tue May 29, 2012 6:31 pm

stiv wrote:The best place to go for questions about *using* blender are the forums at blenderartists.org . Discussions here are more focused on Blender development.
Ok thanks mate :)

ldo
Posts: 544
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Post by ldo » Sat Jun 02, 2012 11:43 am

Can be done. You need to set up a number of things:

* Under the “Image Sampling” panel in the textures tab, make sure “Use” is checked under “Alpha” (I think this is the default).
* Under the “Influence” panel in the textures tab, make sure you have both colour and alpha checked in the “Diffuse” settings.
* Make sure “Transparency” is checked under the materials tab. Specify “Z-transparency”, and turn the Alpha slider all the way down to zero (if you want the fully-transparent parts of the PNG to be completely invisible) or some small value (if you want them to be translucent instead).

That should do it.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests