Serious problems with Blender (publisher, retail version) on

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Posts: 18
Joined: Sun May 11, 2003 2:31 am

Serious problems with Blender (publisher, retail version) on

Postby Qbertino » Wed Jul 23, 2003 2:52 pm

I've been using blender since 3 years but haven't had any kind of problems that are compareable with those I have now.

The first thing that struck just a moment ago is that there is no forum whatsoever dealing with blender problems (or did I overlook something??)

Then there is this problem:
I purchased the blenderpublisher license when it was sold just befor the last instace of NaN went belly-up.

On a relatively fresh Linux (debian woody) it terminates with this error:
blender-publisher-2.25-linux-glibc2.1.2-i386/blenderpublisher: error whi le loading shared libraries: cannot open shared object file: No such file or directory
The newes OSS version (...newpy....) does something simular:
blender-2.27-linux-glibc2.3.2-i386-static$ ./blender
./blender: error while loading shared libraries: cannot open shared object file: No such file or directory
What really disturbs me is the fact that a static version actually shouldn't cause such a problem, because, from what I remember, the term *static* means that all essential libraries are compiled into the programm right from the begining. Please correct me if I'm wrong!

I would appreciate if anybody could tell me where I can get help or maybe even tell me a solution for this problem.
Are their any forums on the internet related to such "basic" problems with blender?
And: Are their *any* versions of blender that run 'out of the box' without causing these troubles? Or is their a version that comes with the required libraries along with it? After all I paid something like 300$ for this...I know NaN has passed away and that's tough luck but still...maybe someone knows help?

Thanks in advance.

Posts: 208
Joined: Wed Oct 16, 2002 7:27 pm
Location: Somewhere below the rivers in Holland (but not Limburg)

Re: Serious problems with Blender (publisher, retail version

Postby Michel » Wed Jul 23, 2003 3:29 pm


The problems you mention are with incompatible versions of glibc. You should be able to get glibc2.1.x for your debian system. That would make blender 2.25 run.

The 2.27-NewPy1 release you mention, was a test release for testing the new Python implementation. At the time I build that Linux version, I had only access to my system - which uses the newest glibc and gcc versions. For the final 2.28 release, I will also have access to a system with older versions of glibc (2.2.5) and gcc. :lol:

About the static-ness of Blender. If you have a static version of Blender on Linux, that means the OpenGL library is linked in Blender, nothing more, nothing less. So, if your graphics card is supported on Linux - and you have 3d accelleration working, you should get the non-static version. Of course, the static version will also work, but without 3d accelleration. :roll:

You should get the 2.27 release of blender (same location as where you got the 2.27-NewPy1 release). I have a really good feeling that one will work on your system. :D

With regards,
You can have one of two things: Progress or Progress Reports.

Posts: 18
Joined: Sun May 11, 2003 2:31 am

Problem solved:

Postby Qbertino » Wed Jul 23, 2003 4:28 pm

You weren't quite right about 2.27 working (it didn't ... and I need the gameengine :-) ) but I solved the problem by doing this (as root):
ln -s /usr/lib/ /usr/lib/

Basically as a Linux user you have to see if you've got the "libstdc++-libc6..." stuff, and see if it's newer then that what Blender wants. Then you have to make a link to the version you've got and name it exactly the way blender wants to have it.

The point is that Blender really requests the exact "". Couldn't Blender be less picky? I mean, obviously newer versions work aswell.

Maybe this can be some help. Thanks for you'rs!
A Gimp/PS debate is pointless. A Blender/LW debate is interesting.

Return to “Interface & Tools”

Who is online

Users browsing this forum: No registered users and 1 guest