Blender renders one "action" behind

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Sat May 12, 2012 7:50 am

Blender renders one "action" behind

Post by sevans » Sat May 12, 2012 7:53 am

My Blender installation is rendering one "action" behind. Any changes made don't show up until I perform another action.

Sample behaviour: I launch the default cube, camera, light file, then switch into edit mode. The display still sees the solid cube selected (hasn't changed from Object Mode). Once I move the view (by pressing 4 on the numpad for example), the display updates with the semi-wireframe cube of the Edit Mode.

This happens with all other behaviours, like deleting, adding objects, etc.

I have tried un-installing, re-installing, rebooting, etc and nothing has worked.

I'm running a Lenovo Windows 7 64bit laptop, i7 2GHz, 8 gigs of ram. Nvidia Geforce GT 555M.

Blender is the only program I've had this problem with. Any suggestions?

I have tried modifying the Window Draw Method. Each option has the same problem.

Posts: 0
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Post by ldo » Sat May 12, 2012 1:41 pm

Tried reinstalling Windows?

Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Sat May 12, 2012 7:15 pm

Maybe a OpenGL problem? NVidia cards usually do well, but you may need nVidia's driver rather than Microsoft's.

Turning off window manager eye candy and transparent themes sometimes helps, but I would do the driver update first.

Posts: 0
Joined: Fri Jul 20, 2012 1:54 pm

I have this same card and the exact same problem.

Post by 26pm » Fri Jul 20, 2012 1:56 pm

I have this same card and the exact same problem. I am a brand new blender user, so this was highly confusing. Blender felt unusable. Have you found a fix for this?

Posts: 0
Joined: Thu Oct 11, 2012 11:02 am


Post by mkovac » Thu Oct 11, 2012 11:08 am

Had exactly the same problem with same graphics card on laptop with both integrated (intel 4000) and discrete (NV GT 555M) graphics card.

In real, this is a problem if Intel integrated graphics, which is used by default by any application. You have to switch preferred graphics card for blender.

1.) Run NVidia control panel
2.) Go to Manage 3D settings and choose Program settings tab
3.) If blender is not among programs, browse and add it
4.) Select high-performance NVIDIA processor for blender
5.) Restart blender.

Post Reply