Fluid simulation problem who's smart to solve?!

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Tue Jan 29, 2013 12:39 pm

Fluid simulation problem who's smart to solve?!

Post by f.o.a.d » Tue Jan 29, 2013 3:28 pm

Hello everybody,

A week ago I traveled from 3ds max to blender hoping that I can use one of it's free features "The fluid simulation".
However after learning it I found out it's not working the way I wanted, so I decided to make a simplified version of the
scene and tried different 'resolutions' to see if the simulator is working at all!!By the way I'm using the latest version of blender 2.65a.
I checked everything many times but still it's not working.This is the problem:
I've got a domain which can only be a simple box, and two 'obstacles' one of which is a simple box shaped glass and the other
is an animated sphere above the glass, the 'fluid' is another cube right inside the glass(FYI: the fluid is not touching the edges of the glass!)
The animation is very sipmple the sphere is falling to the glass which is filled with water(very typical scene!) from frame 10 to say 30.The whole timeline
is set to 0 to 100 frames by the way.
NOW! When I bake the simulation depending on the thickness of the glass object, either nothing happens or the domain object doesn't turn into the
fluid properly(as if I've got no fluid object at all!) I tried different methods to solve the problem but none of it worked.I checked my bake directory
and changed it to a completely new place so that I have a fresh start, I checked the real world size and set it to 1 or 2(my scene is a completely normal scene and
I'm not trying to simulate a tsunami or anything which is far beyond the simulators power whatsoever!) I've also checked the scaling factor of the objects Involved in the simulation
and changed it back to 1 to have a neat transformation matrix BUT still it didn't work! And trust me there is nothing wrong with the settings of the simulation.I have
attached the blend file and you can download it and check for yourself.So guys please tell me what's the problem??! but first check the file!
As I said It's been a week that I'm using blender and I think I'm not welcomed!!!THE MOST RIDICULOUS THING IS THAT
SO I came to this conclusion that there might be an option
which has been switched off for this file by accident.Because I don't understand why the simulation works fine for a scene in a certain file and fails to work in another file for the same scene.
What do you think guys?!I'm so confused!!! Is there any specific option which is been disabled somewhere in blender for this
doomed file?!!I appreciate your help.And thanks very much for reading!

PS: the objects' normals are surely double checked and all recalculated outside also they're all closed meshes!
PSS: no i can't start from scratch and build my original scene! I need a permanent solution!! beside if i do it there is no guarantee that the sim works in the end!

the link to the file: http://dfiles.eu/files/88zxfnu44


Post Reply