Can't import .svg ... no paths option in File>import menu

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Thu Nov 22, 2012 7:10 am
Location: Encino, CA

Can't import .svg ... no paths option in File>import menu

Post by Ruester » Thu Nov 22, 2012 7:16 am

I am using Blender ver 2.64 on Win 7 x64

Every tutorial I see on importing an .svg created in Illustrator tells me to go to File > Import > Paths - BUT Paths doesn't even exist as an option!!

There is an Import > .svg option, but when I import my .svg, nothing happens!!? I also hear there is options for importing an Illustrator file directly, but that doesn't exist in my File > Import options dialogue either...

Can someone tell me how to import my logo created in Illustrator into Blender?

Thanks all

Posts: 0
Joined: Sun Apr 05, 2009 7:42 pm
Location: Germany

Post by CoDEmanX » Thu Nov 22, 2012 8:37 am

The entry "Scalable Vector Graphics (*.svg)" is the right one, if nothing happens on import, then your input SVG is broken or it contains unsupported elements. Many applications like illustrator and inkscape use their custom svg format, make sure you export es standard svg.

There is an external addon for illustrator import: ... AI_PDF_SVG

Note that it's written for blender 2.57, you may have to import with a version up to 2.62, then save and open with blender 2.63+
I'm sitting, waiting, wishing, building Blender in superstition...

Posts: 0
Joined: Thu Aug 08, 2013 2:10 pm

Import Adobe Illustrator, PDF, SVG

Post by crwatson07 » Fri Aug 16, 2013 7:12 pm

Hi, I tried your addon file, io_vector to install in Blender version 2.68a yesterday. I noticed that the file is not working clear. It kept crashing or shutting Blender down after I tried to import the files (*.ai or *.svg).
I think the file may have bugs.
Please check it out.
I would love to use that file because I built many images in Adobe Illustrator and Photoshop.
Please let me know when the io_vector file is fixed.
Thank you.

Post Reply