Blender Crashes on GPU render

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Post Reply
DavidNayias
Posts: 0
Joined: Sat Aug 24, 2013 2:49 am

Blender Crashes on GPU render

Post by DavidNayias » Sat Aug 24, 2013 2:57 am

Hi, I'm hoping someone can help me out with this. I just built a new rig and I was hoping it would overcome this problem but it still crashes.

My old setup was a GTX 650Ti Boost, Intel Core 2 duo 2.8ghz, 4 gigs of ram. And upon rendering with the gpu blender would crash and it would give me a time out error (the 2 second response from GPU). It was about time for me to upgrade my pc so I I upgraded it to this setup:

16gb Ram, i7-4770 @ 3.5ghz and GTX 760

Blender is still crashing when I try to render with the gpu, almost instantly. All I'm rendering is a single character, not super complicated, I have several high res textures for clothes and such, but the textures themselves shouldn't take up more than a couple of hundred megs of ram. I'm running cloth simulation and strand rendering on the hair and I'm rendering with cycles. Mind you I'm only rendering a single frame here and it crashes. I tried turning the hair off and it seems to stop the crashing, but I'm not sure why it crashes with the hair on. I only have about 1200 hairs with 100 children. The GPU doesn't crash in the "render view" but only when its doing a final render. Does anyone have any idea how to fix this?

DavidNayias
Posts: 0
Joined: Sat Aug 24, 2013 2:49 am

Post by DavidNayias » Sat Aug 24, 2013 3:45 am

I guess I should also mention that my old setup was running windows 7 32 bit and the new one is 64 bit.

EdK
Posts: 0
Joined: Sun Jun 09, 2013 5:26 pm

Post by EdK » Thu Sep 05, 2013 12:12 am

I'm considering a GTX 760 too, but this concerns me and I see no one has responded, so maybe this will bump the topic a little.

famouswolf
Posts: 0
Joined: Thu Jul 11, 2013 1:59 pm
Location: Cape Town

Post by famouswolf » Wed Sep 25, 2013 4:29 pm

Hmmm, haven't had a problem like this before.
Would it be possible for you to upload your blend
file somewhere? I'll check if it crashes on my side.
Sound like something with your render settings
if it works in preview mode. Does it still crash if you
turn off all textures? Difficult to say what the problem
might be.

Rolf

aproape
Posts: 0
Joined: Fri Nov 01, 2013 12:02 am

Re: Blender Crashes on GPU render

Post by aproape » Fri Nov 01, 2013 12:09 am

Hi there,

blender scene file would definitely help.. as well as the exact blender version/built.

I had GTX 580.. then 580 SLI.. then 780.. and now 780 SLI. Never had an issue rendering quite a few scenes on GPU only.

Also would be good to know the nvidia driver version, render settings [are you trying Cycles/CUDA? or another renderer]


Cheers,
Alex

DavidNayias wrote:Hi, I'm hoping someone can help me out with this. I just built a new rig and I was hoping it would overcome this problem but it still crashes.

My old setup was a GTX 650Ti Boost, Intel Core 2 duo 2.8ghz, 4 gigs of ram. And upon rendering with the gpu blender would crash and it would give me a time out error (the 2 second response from GPU). It was about time for me to upgrade my pc so I I upgraded it to this setup:

16gb Ram, i7-4770 @ 3.5ghz and GTX 760

Blender is still crashing when I try to render with the gpu, almost instantly. All I'm rendering is a single character, not super complicated, I have several high res textures for clothes and such, but the textures themselves shouldn't take up more than a couple of hundred megs of ram. I'm running cloth simulation and strand rendering on the hair and I'm rendering with cycles. Mind you I'm only rendering a single frame here and it crashes. I tried turning the hair off and it seems to stop the crashing, but I'm not sure why it crashes with the hair on. I only have about 1200 hairs with 100 children. The GPU doesn't crash in the "render view" but only when its doing a final render. Does anyone have any idea how to fix this?

Post Reply