compiling 2.32

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Fri Nov 14, 2003 4:04 pm

compiling 2.32

Post by Antares »

hi there

i currently trying to compile the blender 2.32 source, but it isnt working. first of all i found a function that is no longer in use and contains some weird statements.

Code: Select all

<<<<<<< rendercore.c
void shadepixel(float x, float y, int vlaknr)
  /* x,y: window coordinate from 0 to rectx,y */

	static VlakRen *vlr;
	static VertRen *v1, *v2, *v3;
	static float t00, t01, t10, t11, dvlak, n1[3], n2[3], n3[3];
	static float s00, s01, s10, s11;
	float *o1, *o2, *o3;
	float u, v, l, dl, hox, hoy, detsh, fac, deler, alpha;
	char *cp1, *cp2, *cp3;

	if(R.vlaknr== -1) {	/* does initrender */
		vlr= R.vlr= 0;
	if(i2==1) {
		v2= vlr->v2;
		p2= ME_FLIPV2;
	} else {
		v2= vlr->v3;
		p2= ME_FLIPV3;
>>>>>>> 1.48
	if(i3==2) {
		v3= vlr->v3;
		p3= ME_FLIPV3;
	} else {
		v3= vlr->v4;
		p3= ME_FLIPV4;

	/* calculate U and V, for scanline (normal u and v are -1 to 0) */
	if(u==1.0) {
after deleting this code i as able to compile the source the first time, but wen i rendered something (simple cube from the initial scene) the cube was all black.

if i switch under materials to "shadeless" at least the selected color is visible.

at the moment i am going throught the "shadepixel()" function to find the error, but help would be much appreciated.

my goal is to compile the source with the intel compiler again. if i switch to optimized settings for the BRE_render module the cube mentioned above is blue (RGB: 0,0,255) instead of black.

could someone who worked on this module give me a hint how to fix this plz?

thx in advance

Posts: 0
Joined: Fri Nov 14, 2003 4:04 pm

Post by Antares »

ok solved it myself

the "rendercore.c" under BRE_render cvs-version was messed up. i used the file from the source available at after replacing that file everything was fine ^^

new intel compiler opimized version available under

rendering times for my testpic droped from 343 seconds to 107 seconds.

again quite amazing isnt it?

Posts: 0
Joined: Sun Apr 06, 2003 2:22 pm
Location: Wellington, New Zealand

Post by alien-xmp »


usually happens when the same piece of source code is changed by both you and another developer in the repository. CVS can't decide which bit to use, so leaves it up to you to make the decision.

Post Reply